HDU 1856 More is better【并查集】

解题思路:将给出的男孩的关系合并后,另用一个数组a记录以find(i)为根节点的元素的个数,最后找出数组a的最大值

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others) Total Submission(s): 15861    Accepted Submission(s): 5843

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.
Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 
Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 
Sample Output
4 2
#include<stdio.h>
#include<string.h>
 int pre[10000010],a[10000010];
 int find( int root)
{
	if(root!=pre[root])
	pre[root]=find(pre[root]);
	return pre[root];
}
void unionroot( int root1,int root2)
{
	 int x,y;
	x=find(root1);
	y=find(root2);
	if(x!=y)
	pre[x]=y;
}

int main()
{
	int n;
	int root1,root2,x,y,k,i,max;
	while(scanf("%d",&n)!=EOF)
	{
		max=-100000;
		for(i=1;i<=10000010;i++)
		a[i]=0;
	
		for(i=1;i<=10000010;i++)
		pre[i]=i;
		while(n--)
		{
			scanf("%d %d",&root1,&root2);
			x=find(root1);
			y=find(root2);
			unionroot(x,y);
		}
		
		for(i=1;i<=10000010;i++)
		{
			k=find(i);
			a[k]++;//记录以find(i)为根节点的包含有多少 个元素 
		}
		for(i=1;i<=10000010;i++)
		{
			if(a[i]>max)
			max=a[i];
		}
		printf("%d\n",max);		
	}
}

  

 

转载于:https://www.cnblogs.com/wuyuewoniu/p/4202541.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值