UVA11582 - Colossal Fibonacci Numbers!

The i’th Fibonacci number f(i) is recursively defined in the following way:

• f(0) = 0 and f(1) = 1                      • f(i + 2) = f(i + 1) + f(i) for every i ≥ 0

Your task is to compute some values of this sequence.

Input

Input begins with an integer t ≤ 10, 000, the number of test cases. Each test case consists of three integers a, b, n where 0 ≤ a, b < 2 64 (a and b will not both be zero) and 1 ≤ n ≤ 1000.

Output

For each test case, output a single line containing the remainder of f(a b ) upon division by n.

Sample Input

3

1 1 2

2 3 1000

18446744073709551615 18446744073709551615 1000

Sample Output

1

21

250

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

const int maxn=1000000+5;
typedef unsigned long long ull;
int modnum[maxn];
int Mod;

int powermod(ull a,ull b,int c)
{
    ull ans=1;
    a%=c;
    while(b)
    {
        if(b&1)
           ans=ans*a%c;
        a=a*a%c;
        b=b>>1;
    }
    return ans;
}
int main()
{
    
    int t;
    ull a,b;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%llu%llu%d",&a,&b,&Mod);
        if(Mod==1 || a==0)
        {
            printf("0\n");
            continue;
        }
        modnum[0]=modnum[1]=1;
        int p=1;
        for(int i=2;;i++)
        {
            modnum[i]=(modnum[i-1]+modnum[i-2])%Mod;
            if(modnum[i]==1 && modnum[i-1]==1)
            {
                p=i-1;
                break;
            }
        }
        printf("%d\n",modnum[powermod(a,b,p)-1]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/aerer/p/9931030.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值