2017ACM暑期多校联合训练 - Team 9 1005 HDU 6165 FFF at Valentine (dfs)

题目链接

Problem Description

1149206-20170823110219402-65476401.png

At Valentine's eve, Shylock and Lucar were enjoying their time as any other couples. Suddenly, LSH, Boss of FFF Group caught both of them, and locked them into two separate cells of the jail randomly. But as the saying goes: There is always a way out , the lovers made a bet with LSH: if either of them can reach the cell of the other one, then LSH has to let them go.
The jail is formed of several cells and each cell has some special portals connect to a specific cell. One can be transported to the connected cell by the portal, but be transported back is impossible. There will not be a portal connecting a cell and itself, and since the cost of a portal is pretty expensive, LSH would not tolerate the fact that two portals connect exactly the same two cells.
As an enthusiastic person of the FFF group, YOU are quit curious about whether the lovers can survive or not. So you get a map of the jail and decide to figure it out.

Input
∙Input starts with an integer T (T≤120), denoting the number of test cases.
∙For each case,
First line is two number n and m, the total number of cells and portals in the jail.(2≤n≤1000,m≤6000)
Then next m lines each contains two integer u and v, which indicates a portal from u to v.

Output
If the couple can survive, print “I love you my love and our love save us!”
Otherwise, print “Light my fire!”

Sample Input
3
5 5
1 2
2 3
2 4
3 5
4 5

3 3
1 2
2 3
3 1

5 5
1 2
2 3
3 1
3 4
4 5

Sample Output
Light my fire!
I love you my love and our love save us!
I love you my love and our love save us!

题意:

给定n个点,这n个点之间连有m条单向的路径,要求判断整个图中是否满足任意两点之间有路径可以到达。

(如果求点a与点b之间,只要a能够到达b,或则b能够到达a即可)

分析:

最终的意思还是判断任意两点之间是否由路径到达,最开始的时候用dij来写,调用n次,可能中间的哪一个细节没有考虑到,反正就是w。

然后改变了一下思路,从一个点出发,寻找所有的这个点能够达到的点,刚开始的时候肯定是只考虑它本身能够达到的,但这样是不够的,我们还要考虑所有的通过某些点可以到达的点。将所有的点都要走一遍。

代码:

#include<bits/stdc++.h>
using namespace std;

const int N = 1000 + 5;
int dp[N][N];//可达标记
bool vis[N];
vector<int> son[N];

void dfs(int u,int fa)
{
    dp[fa][u]=vis[u]=1;//记为可达
    for(int i=0; i<son[u].size(); i++)///标记了从节点fa可以到达的使所有的节点,不仅仅是直接相连的,通过其他的点松弛过的也要标记
    {
        int v=son[u][i];
        if(!vis[v])
        {
            dfs(v,fa);
        }
    }
}

int main()
{
    int t,m,n,u,v;
    bool flag;
    scanf("%d",&t);
    while(t--)
    {
        flag=1;
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&m);
        for(int i=0; i<=n; i++)
        {
            son[i].clear();
        }
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&u,&v);
            dp[u][v]=1;///u到v有路径
            son[u].push_back(v);///记录这个点可以达到的所有的点
        }
        for(int i=1; i<=n; i++)///从每一个点出发开始标记路径
        {
            memset(vis,0,sizeof(vis));
            vis[i]=1;
            dfs(i,i);
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<i; j++)
            {
                if(dp[i][j]||dp[j][i]) ///只要两点之间有一方能够到达另一方即可
                    continue;
                else
                {
                    flag=0;///都不能到达的话,做一个标记
                    break;
                }
            }
            if(flag==0)
                break;
        }
        if(flag)
        {
            puts("I love you my love and our love save us!");
        }
        else
        {
            puts("Light my fire!");
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/cmmdc/p/7417201.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
本火锅店点餐系统采用Java语言和Vue技术,框架采用SSM,搭配Mysql数据库,运行在Idea里,采用小程序模式。本火锅店点餐系统提供管理员、用户两种角色的服务。总的功能包括菜品的查询、菜品的购买、餐桌预定和订单管理。本系统可以帮助管理员更新菜品信息和管理订单信息,帮助用户实现在线的点餐方式,并可以实现餐桌预定。本系统采用成熟技术开发可以完成点餐管理的相关工作。 本系统的功能围绕用户、管理员两种权限设计。根据不同权限的不同需求设计出更符合用户要求的功能。本系统中管理员主要负责审核管理用户,发布分享新的菜品,审核用户的订餐信息和餐桌预定信息等,用户可以对需要的菜品进行购买、预定餐桌等。用户可以管理个人资料、查询菜品、在线点餐和预定餐桌、管理订单等,用户的个人资料是由管理员添加用户资料时产生,用户的订单内容由用户在购买菜品时产生,用户预定信息由用户在预定餐桌操作时产生。 本系统的功能设计为管理员、用户两部分。管理员为菜品管理、菜品分类管理、用户管理、订单管理等,用户的功能为查询菜品,在线点餐、预定餐桌、管理个人信息等。 管理员负责用户信息的删除和管理,用户的姓名和手机号都可以由管理员在此功能里看到。管理员可以对菜品的信息进行管理、审核。本功能可以实现菜品的定时更新和审核管理。本功能包括查询餐桌,也可以发布新的餐桌信息。管理员可以查询已预定的餐桌,并进行审核。管理员可以管理公告和系统的轮播图,可以安排活动。管理员可以对个人的资料进行修改和管理,管理员还可以在本功能里修改密码。管理员可以查询用户的订单,并完成菜品的安排。 当用户登录进系统后可以修改自己的资料,可以使自己信息的保持正确性。还可以修改密码。用户可以浏览所有的菜品,可以查看详细的菜品内容,也可以进行菜品的点餐。在本功能里用户可以进行点餐。用户可以浏览没有预定出去的餐桌,选择合适的餐桌可以进行预定。用户可以管理购物车里的菜品。用户可以管理自己的订单,在订单管理界面里也可以进行查询操作。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值