poj2945 Find the Clones

Find the Clones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8490 Accepted: 3210

Description

Doubleville, a small town in Texas, was attacked by the aliens. They have abducted some of the residents and taken them to the a spaceship orbiting around earth. After some (quite unpleasant) human experiments, the aliens cloned the victims, and released multiple copies of them back in Doubleville. So now it might happen that there are 6 identical person named Hugh F. Bumblebee: the original person and its 5 copies. The Federal Bureau of Unauthorized Cloning (FBUC) charged you with the task of determining how many copies were made from each person. To help you in your task, FBUC have collected a DNA sample from each person. All copies of the same person have the same DNA sequence, and different people have different sequences (we know that there are no identical twins in the town, this is not an issue).

Input

The input contains several blocks of test cases. Each case begins with a line containing two integers: the number 1 ≤ n ≤ 20000 people, and the length 1 ≤ m ≤ 20 of the DNA sequences. The next n lines contain the DNA sequences: each line contains a sequence of m characters, where each character is either `A', `C', `G' or `T'. 

The input is terminated by a block with n = m = 0 .

Output

For each test case, you have to output n lines, each line containing a single integer. The first line contains the number of different people that were not copied. The second line contains the number of people that were copied only once (i.e., there are two identical copies for each such person.) The third line contains the number of people that are present in three identical copies, and so on: the i -th line contains the number of persons that are present in i identical copies. For example, if there are 11 samples, one of them is from John Smith, and all the others are from copies of Joe Foobar, then you have to print `1' in the first andthe tenth lines, and `0' in all the other lines.

Sample Input

9 6
AAAAAA
ACACAC
GTTTTG
ACACAC
GTTTTG
ACACAC
ACACAC
TCCCCC
TCCCCC
0 0

Sample Output

1
2
0
1
0
0
0
0
0

Hint

Huge input file, 'scanf' recommended to avoid TLE. 

Source

大致题意:求1到n中有i个相同的字符串有多少种.
分析:字符串很多,直接hash或者map可能会爆掉,但是每个字符串长度很小,可以用trie,最后统计结尾标记的个数即可.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int n, len, tot, ans[1000010];
char s[30];

struct node
{
    int tr[30];
    int end;
    void clear()
    {
        memset(tr, 0, sizeof(tr));
        end = 0;
    }
}e[1000010];

void insert(char *ss)
{
    int u = 1;
    for (int i = 1; i <= len; i++)
    {
        if (!e[u].tr[ss[i] - 'A'])
            e[u].tr[ss[i] - 'A'] = ++tot;
        u = e[u].tr[ss[i] - 'A'];
    }
    e[u].end++;
}

int main()
{
    while (scanf("%d%d", &n, &len) && (n || len))
    {
        memset(ans, 0, sizeof(ans));
        for (int i = 1; i <= tot; i++)
            e[i].clear();
        tot = 0;
        for (int i = 1; i <= n; i++)
        {
            scanf("%s", s + 1);
            insert(s);
        }
        for (int i = 1; i <= tot; i++)
            ans[e[i].end]++;
        for (int i = 1; i <= n; i++)
            printf("%d\n", ans[i]);
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/zbtrs/p/8047152.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值