PAT-1049. Counting Ones (30)

1049. Counting Ones (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:
12
Sample Output:
5

暴力枚举超时,经过探究,发现可以算出每一位是1的个数,对于这种找规律的题,我们可以观察简单的例子来推出规律,写出程序,测试复杂情况是否可行。

具体规律看代码,讲起来很复杂。

 

#include <bits/stdc++.h>

using namespace std;

int N;
int total;

void getOnes(int n, int m, int cnt) {
    if(n == 0) return;
    int a = n % 10;
    int b = n / 10;
    int c = cnt;
    int d = 1;
    while(c--) {
        d *= 10;
    }
    if(a < 1) {
        total += b*d;
    }
    else if(a > 1) {
        total += (b+1)*d;
    }
    else {
        total += b*d+m+1;
    }
    m += a*d;
    getOnes(b, m, cnt+1);
}

int main()
{
    cin>> N;
    getOnes(N, 0, 0);
    cout<< total;
    return 0;
}

 

转载于:https://www.cnblogs.com/ACMessi/p/8442746.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值