ACM-简单题之As Easy As A+B——hdu1040

版权声明:本文为博主原创文章,未经博主同意不得转载。 https://blog.csdn.net/lx417147512/article/details/28855499

***************************************转载请注明出处:http://blog.csdn.net/lttree***************************************



As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35503    Accepted Submission(s): 15331


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B?

It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
 
    
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

Sample Output
 
    
1 2 3 1 2 3 4 5 6 7 8 9
 

Author
lcy
 

题目:http://acm.hdu.edu.cn/showproblem.php?

pid=1040


做一道简单题吧,题目也说了。和A+B一样简单。

求一些数的升序。就一个排序就能够了,并且数据范围就1000.


/******************************************* 
******************************************** 
*           Author:Tree                    * 
*    From :  blog.csdn.net/lttree          * 
*      Title : As Easy As A+B              * 
*    Source: hdu 1040                      * 
*      Hint :  简单题                      * 
******************************************** 
*******************************************/  

#include <stdio.h>
#include <algorithm>
using namespace std;
int a[1005];
int main()
{
	int i,n,t;
	scanf("%d",&t);
	while( t-- )
	{
		scanf("%d",&n);
		for( i=0;i<n;++i )
			scanf("%d",&a[i]);
		sort(a,a+n);
		for( i=0;i<n-1;++i )
			printf("%d ",a[i]);
		printf("%d\n",a[n-1]);
	}
	return 0;
}


转载于:https://www.cnblogs.com/xfgnongmin/p/10851137.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值