To the Max

 

Description

 


Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.

Input

 


The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

 


Output the sum of the maximal sub-rectangle.

Sample Input

 

40 -2 -7 0 9 2 -6 2-4 1 -4  1 -18  0 -2

Sample Output

 

15
/********代码******枚举*****DP***************/

 

ContractedBlock.gif ExpandedBlockStart.gif 代码
#include<stdio.h>
int main()
{
 int n,i,j,k,l,ii,h,max,Max;
 int map[101][101],sum[101],s[101];
 while(scanf("%d",&n)!=EOF){
  for(i=0;i<n;i++){  
   for(j=0;j<n;j++) 
    scanf("%d",&map[i][j]);
  }  Max=0; 
  for(i=0;i<n;i++){
   for(j=i;j<n;j++){ //从第i列到第j列
    for(k=0;k<n;k++)
     sum[k]=s[k]=0;
    max=-127;
    for(k=0;k<n;k++){
     for(l=i;l<=j;l++)
      s[k]+=map[k][l]; //s[k]为敌k行的值(从第i列到第j列)
     if(sum[k]>0)
      sum[k+1]=sum[k]+s[k]; //sum[k]为到k行是的最大值(从第i列到第j列) 
     else sum[k+1]=s[k];   
     if(sum[k+1]>max)max=sum[k+1]; //max记录最大值(从第i列到第j列) 
    }  
    if(max>Max)       //Max记录总的最大值   
     Max=max;  
   }
  }
  printf("%d\n",Max);
 }
 return 0;
}

 

转载于:https://www.cnblogs.com/pictureyong/archive/2010/07/14/1777298.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值