zoj 3823 Excavator Contest 构造

Excavator Contest

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3823

Description

Bluefly University is famous of excavator technology. Lots of students take part in many excavator-related courses. After the students finish their courses, they will compete in a contest called International Collegiate Excavator Contest (ICEC).

 

An excavator

 

This year's ICEC will be held at Marjar University. This is an individual competition that each contestant will start the match one by one.

The task of the contest is to drive an excavator passing a square field. The judge partitioned the field into N × N equal-sized square chunks. Each chunk should be visited exactly one time. The contestant will drive the excavator, starting from and ending at the center of two different boundary chunks.

In order to show off their superb excavator operating skills, the contestants need to drive the excavator with as many as possible turnings. Since the excavator is a kind of large and heavy vehicle, it can only make a turn to left or right at the center of any chunk.

Bob is a student from Marjar University. He wants to win the contest. To fulfill this dream, he needs to drive the excavator with at least N× (N - 1) - 1 turnings. It seems to be a difficult task, so he turns to you for help. Please write a program to find a feasible route for him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one integer N (2 <= N <= 512).

Output

For each test case, output a matrix with N × N integers indicating the route to pass all the chunks. Bob will drive the excavator passing the chunks in the order of 1, 2, .., N2.

If there are multiple solutions, any one will be acceptable.

Sample Input

2
4
3
 

Sample Output

2 1 16 15
3 4 13 14
6 5 12 11
7 8 9 10
1 2 3
8 7 4
9 6 5

HINT

 

题意

给你一个n*n个格子,然后让你跑,使得起点和终点都必须在边界上

而且使得转弯次数至少是n*(n-1)-1次

题解:

分奇数偶数构造

大概偶数特别容易想

奇数比较麻烦,奇数在我的构造方式下,要转圈圈

反正就非常迷就是了……

代码:

//qscqesze
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <bitset>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 100006
#define mod 1000000007
#define eps 1e-9
#define e exp(1.0)
#define PI acos(-1)
const double EP  = 1E-10 ;
int Num;
//const int inf=0x7fffffff;
const ll inf=999999999;
inline ll read()
{
    ll x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
//*************************************************************************************

int A[600][600];
int B[600][600];
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        int n;scanf("%d",&n);
        if(n%2==0)
        {
            int nowx= 1,nowy = 1;
            int now = 1;
            while(now<=n*n)
            {
                A[nowy][nowx]=now;
                if(nowy<=n-2)
                {
                    if(nowx%4==1)
                    {
                        if(nowy%2==1)
                            nowx=nowx+1;
                        else
                            nowy=nowy+1;
                    }
                    else if(nowx%4==2)
                    {
                        if(nowy%2==1)
                            nowy=nowy+1;
                        else
                            nowx=nowx-1;
                    }
                    else if(nowx%4==3)
                    {
                        if(nowy%2==1)
                            nowx=nowx+1;
                        else
                            nowy=nowy-1;
                    }
                    else
                    {
                        if(nowy==1)
                            nowx=nowx+1;
                        else if(nowy%2==1)
                            nowy=nowy-1;
                        else
                            nowx=nowx-1;
                    }
                }
                else
                {
                    if(nowx%4==1)
                    {
                        if(nowy==n-1)
                            nowy=nowy+1;
                        else
                            nowx=nowx+1;
                    }
                    else if(nowx%4==2)
                    {
                        if(nowy==n-1)
                            nowx=nowx+1;
                        else
                            nowy=nowy-1;
                    }
                    else if(nowx%4==3)
                    {
                        if(nowy==n-1)
                            nowy=nowy+1;
                        else
                            nowx=nowx+1;
                    }
                    else
                    {
                        nowy=nowy-1;
                    }
                }
                now++;
            }
        }
        else
        {
            A[1][1]=1;
            int nowx = 1;
            int nowy = 1;
            int now = 2;
            for(int i=3;i<=n;i+=2)
            {
                for(int ii=1;ii<=i-2;ii++)
                {
                    for(int jj=1;jj<=i-2;jj++)
                    {
                        B[ii][jj]=A[ii][jj];
                    }
                }

                for(int ii=1;ii<=i-2;ii++)
                {
                    for(int jj=1;jj<=i-2;jj++)
                    {
                        A[ii][jj]=(i-2)*(i-2)+1-B[i-1-jj][ii];
                    }
                }
                nowx = 1,nowy = i-1;
                while(now<=i*i)
                {
                    A[nowx][nowy]=now;
                    if(nowx<=i-2)
                    {
                        if(nowx%2==1)
                        {
                            if(nowy==i-1)
                                nowy=nowy+1;
                            else
                                nowx=nowx+1;
                        }
                        else
                        {
                            if(nowy==i)
                                nowy=nowy-1;
                            else
                                nowx=nowx+1;
                        }
                    }
                    else
                    {
                        if(nowx==i-1)
                        {
                            if(nowy%2==0)
                                nowy=nowy-1;
                            else
                                nowx=nowx+1;
                        }
                        else
                        {
                            if(nowy%2==0)
                                nowx=nowx-1;
                            else
                                nowy=nowy-1;
                        }
                    }
                    now++;
                }

            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                printf("%d ",A[i][j]);
            }
            printf("\n");
        }
    }
}

 

转载于:https://www.cnblogs.com/qscqesze/p/4836573.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值