ZOJ - 3204 Connect them 最小生成树

Connect them ZOJ - 3204

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers iand j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cjicii= 0, 1 <= ij <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1 i1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

<b< dd="">

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1


题意:最小生成树,但要求最小字典序的解。
那么变化就是在cmp的函数书写的,不能仅仅的比较value,还要把from,to按字典序的顺序来加入,当然输出也是如此。
所以重写两个cmp函数就可以了。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=105;
int T,x;
int n,p,q;
int cnt,sum;
struct Node
{
    int from,to;
    double value;
}node[maxn*maxn],ans[maxn*maxn];
int fa[maxn];
bool cmp(Node a,Node b)
{
    if(a.value!=b.value)
        return a.value<b.value;
    else if(a.from!=b.from)
        return a.from<b.from;
    else
        return a.to<b.to;
}
bool cmpp(Node a,Node b)
{
    if(a.from==b.from)
        return a.to<b.to;
    else
        return a.from<b.from;
}
void init()
{
    for(int i=0;i<maxn;i++)
        fa[i]=i;
}
int findd(int x)
{
    if(fa[x]==x)
        return x;
    else
        return fa[x]=findd(fa[x]);
}
void Kruskal()
{
    sum=0;
    for(int i=1;i<=cnt;i++)
    {
        int fx=findd(node[i].from);
        int fy=findd(node[i].to);
        if(fx!=fy)
        {
            ans[sum++]=node[i];
            fa[fx]=fy;
        }
    }
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        cnt=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&x);
                if(x==0||j<=i)
                    continue;
                cnt++;
                node[cnt].from=i;node[cnt].to=j;
                node[cnt].value=x;
            }
        }
        init();
        sort(node+1,node+cnt+1,cmp);
        sum=0;
        Kruskal();
        if(sum!=n-1)
        {
            printf("-1\n");
            continue;
        }
        else
        {
            sort(ans,ans+sum,cmpp);
            for(int i=0;i<sum-1;i++)
                printf("%d %d ",ans[i].from,ans[i].to);
            printf("%d %d\n",ans[sum-1].from,ans[sum-1].to);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jkzr/p/10021603.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值