微软2014校招笔试题-String reorder

Time Limit: 10000ms
Case Time Limit: 1000ms
Memory Limit: 256MB

Description

For this question, your program is required to process an input string containing only ASCII characters between ‘0’ and ‘9’, or between ‘a’ and ‘z’ (including ‘0’, ‘9’, ‘a’, ‘z’).

Your program should reorder and split all input string characters into multiple segments, and output all segments as one concatenated string. The following requirements should also be met,
1. Characters in each segment should be in strictly increasing order. For ordering, ‘9’ is larger than ‘0’, ‘a’ is larger than ‘9’, and ‘z’ is larger than ‘a’ (basically following ASCII character order).
2. Characters in the second segment must be the same as or a subset of the first segment; and every following segment must be the same as or a subset of its previous segment.

Your program should output string “<invalid input string>” when the input contains any invalid characters (i.e., outside the '0'-'9' and 'a'-'z' range).


Input


Input consists of multiple cases, one case per line. Each case is one string consisting of ASCII characters.

Output


For each case, print exactly one line with the reordered string based on the criteria above.

Sample Input
aabbccdd
007799aabbccddeeff113355zz
1234.89898
abcdefabcdefabcdefaaaaaaaaaaaaaabbbbbbbddddddee
Sample Output
abcdabcd
013579abcdefz013579abcdefz
<invalid input string>
abcdefabcdefabcdefabdeabdeabdabdabdabdabaaaaaaa



我的水平有限,但最终也解答出来了。下面贴出个人的答案,欢迎大牛批评指正。

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace StringReorder
{
    class Program
    {

        static void Main(string[] args)
        {
            string input = string.Empty;
            input = Console.ReadLine();

            GetResults(input);

        }

        static void GetResults(string input)
        {
            string results = "";
            if (MatchRequirement(input))
            {
                List<char> inputCharList = sort(input).ToList();
                List<char> tempList = new List<char>();
                while (inputCharList.Count > 0)
                {

                    tempList.Add(inputCharList[0]);
                    inputCharList.RemoveAt(0);
                    int i = 0;
                    while (i < inputCharList.Count)
                    {
                        if (inputCharList[i] > tempList[tempList.Count - 1])
                        {
                            tempList.Add(inputCharList[i]);
                            inputCharList.RemoveAt(i);
                        }
                        else
                        {
                            i++;
                        }

                    }
                    results += ListToString(tempList);
                    tempList.Clear();
                }
                Console.WriteLine(results);
            }
        }

        static string ListToString(List<char> tempList)
        {
            string tempStr = "";
            for (int i = 0; i < tempList.Count; i++)
            {
                tempStr += tempList[i];
            }
            return tempStr;
        }
        static string sort(string inputString)
        {
            char[] inputChars = inputString.ToArray();
            string tempStr = "";
            Array.Sort(inputChars);
            for (int i = 0; i < inputChars.Length; i++)
            {
                tempStr += inputChars[i];
            }
            return tempStr;
        }
        static bool MatchRequirement(string inputString)
        {
            bool tempValue = false;
            char[] inputChars = inputString.ToArray();

            for (int i = 0; i < inputChars.Length; i++)
            {
                if (!match(inputChars[i]))
                {
                    Console.WriteLine("<invalid input string>");
                    tempValue = false;
                    break;
                }
                else
                {
                    tempValue = true;
                }

            }
            return tempValue;
        }
        static bool match(char c)
        {
            if ((c >= '0' && c <= '9') || (c >= 'a' && c <= 'z'))
            {
                return true;
            }
            return false;
        }
    }
}


转载于:https://www.cnblogs.com/mantgh/p/3661421.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
4S店客户管理小程序-毕业设计,基于微信小程序+SSM+MySql开发,源码+数据库+论文答辩+毕业论文+视频演示 社会的发展和科学技术的进步,互联网技术越来越受欢迎。手机也逐渐受到广大人民群众的喜爱,也逐渐进入了每个用户的使用。手机具有便利性,速度快,效率高,成本低等优点。 因此,构建符合自己要求的操作系统是非常有意义的。 本文从管理员、用户的功能要求出发,4S店客户管理系统中的功能模块主要是实现管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理,用户客户端:首页、车展、新闻头条、我的。门店客户端:首页、车展、新闻头条、我的经过认真细致的研究,精心准备和规划,最后测试成功,系统可以正常使用。分析功能调整与4S店客户管理系统实现的实际需求相结合,讨论了微信开发者技术与后台结合java语言和MySQL数据库开发4S店客户管理系统的使用。 关键字:4S店客户管理系统小程序 微信开发者 Java技术 MySQL数据库 软件的功能: 1、开发实现4S店客户管理系统的整个系统程序; 2、管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理等。 3、用户客户端:首页、车展、新闻头条、我的 4、门店客户端:首页、车展、新闻头条、我的等相应操作; 5、基础数据管理:实现系统基本信息的添加、修改及删除等操作,并且根据需求进行交流信息的查看及回复相应操作。
现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本微信小程序医院挂号预约系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此微信小程序医院挂号预约系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。微信小程序医院挂号预约系统有管理员,用户两个角色。管理员功能有个人中心,用户管理,医生信息管理,医院信息管理,科室信息管理,预约信息管理,预约取消管理,留言板,系统管理。微信小程序用户可以注册登录,查看医院信息,查看医生信息,查看公告资讯,在科室信息里面进行预约,也可以取消预约。微信小程序医院挂号预约系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值