UVALive 7146

Long long ago there is a strong tribe living on the earth. They always have wars and eonquer others.One day, there is another tribe become their target. The strong tribe has decide to terminate them!!!There are m villages in the other tribe. Each village contains a troop with attack power EAttacki,and defense power EDefensei. Our tribe has n troops to attack the enemy. Each troop also has theattack power Attacki, and defense power Defensei. We can use at most one troop to attack one enemyvillage and a troop can only be used to attack only one enemy village. Even if a troop survives anattack, it can’t be used again in another attack.The battle between 2 troops are really simple. The troops use their attack power to attack againstthe other troop simultaneously. If a troop’s defense power is less than or equal to the other troop’sattack power, it will be destroyed. It’s possible that both troops survive or destroy.The main target of our tribe is to destroy all the enemy troops. Also, our tribe would like to havemost number of troops survive in this war.

Input 

The first line of the input gives the number of test cases, T. T test cases follow. Each test case startwith 2 numbers n and m, the number of our troops and the number of enemy villages. n lines follow,each with Attacki and Defensei, the attack power and defense power of our troops. The next mlines describe the enemy troops. Each line consist of EAttacki and EDefensei, the attack power anddefense power of enemy troops

Output

For each test ease, output one line containing ‘Case #x: y’, where x is the test case number (startingfrom 1) and y is the max number of survive troops of our tribe. If it‘s impossible to destroy all enemytroops, output ‘-1’ instead.Limits:1 ≤ T ≤ 100,1 ≤ n, m ≤ 105,1 ≤ Attacki, Defensei, EAttacki, EDefensei ≤ 109,

Sample Input

3 2

5 7

7 3

1 2

4 4

2 2

2 1

3 4

1 10

5 6

Sample Output

Case #1: 3

Case #2: -1


题意:我方有n个军队,敌方有m个军队,每一个军队有攻击力a[i].l和防御力a[i].r,我方的每一个军队只能攻击一个敌方的军队,且只能攻击一次,当攻击的军队的攻击力大于等于敌方的防御力,若防御力大于等于敌方的攻击力,那么敌方军队消灭,且我方攻击的军队还存在,否则我两个军队同归于尽,问要把敌方的m个军队都消灭,我方至少损失多少军队。

思路:可以先把两个的军队分别按攻击力从大到小排序,依次询问敌方m个军队,把我方攻击力大于当前询问的敌方军队的军队都加入到set里面,然后再set里找到比当前询问的敌方军队防御力第一个大的军队,用它把它消灭,如果找不到,那么直接break或者删去set里的第一个。


#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 0x7fffffff
#define maxn 100050
struct node{
    int l,r;
}a[maxn],b[maxn];

bool cmp(node a,node b){
    return a.l>b.l;
}

multiset<int>myset;
multiset<int>::iterator it;
int main()
{
    int n,m,i,j,T,t,ans;
    scanf("%d",&T);
    int num1=0;
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++){
            scanf("%d%d",&a[i].l,&a[i].r);
        }
        for(i=1;i<=m;i++){
            scanf("%d%d",&b[i].r,&b[i].l);
        }
        sort(a+1,a+1+n,cmp);
        sort(b+1,b+1+m,cmp);
        myset.clear();
        t=1;ans=n;
        for(i=1;i<=m;i++){
            while(t<=n && a[t].l>=b[i].l){
                myset.insert(a[t].r);t++;
            }
            if(myset.size()==0){
                ans=-1;break;
            }
            it=myset.upper_bound(b[i].r);
            if(it==myset.end()){
                ans--;
                myset.erase(myset.begin() );
            }
            else{
                myset.erase(it);
            }
        }
        num1++;
        printf("Case #%d: %d\n",num1,ans);

    }
    return 0;
}


转载于:https://www.cnblogs.com/herumw/p/9464646.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值