hdu 2101 A + B Problem Too(数论)

A + B Problem Too

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8373    Accepted Submission(s): 6277


Problem Description
This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.


 

Input
Each line will contain two integers A and B. Process to end of file.


 

Output
For each case, if(A+B)%86=0,output yes in one line,else output no in one line.


 

Sample Input
 
  
1 1 8600 8600


 

Sample Output
 
  
no yes


 

Source


 

Recommend
xhd

 

思路:(10*a+b)%c=((a%c)*10+b)%c;

 

#include<iostream>
using namespace std;
const int mm=100010;
char s[mm],ss[mm];
int main()
{ int ans,anss;
  while(cin>>s>>ss)
  {
    ans=anss=0;
    for(int i=0;s[i]!='\0';i++)
    {
      ans=(ans*10+s[i]-'0')%86;
    }
    for(int i=0;ss[i]!='\0';i++)
      anss=(anss*10+ss[i]-'0')%86;
    ans=(ans+anss)%86;
    if(ans)cout<<"no\n";
    else cout<<"yes\n";
  }
}


 

 

 

转载于:https://www.cnblogs.com/nealgavin/archive/2013/01/13/3206187.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值