PAT 1099. Build A Binary Search Tree (树的中序,层序遍历)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.
    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

h8_nkqjeu5lglo.jpg
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

分析

这道题就是已知一个二叉搜索树的树形和节点的元素,叫你把元素填进去,然后输出层序遍历的结果,其实由二叉搜索树中序遍历的性质可知其中序遍历的结果是升序的,所以先把节点元素从小到大排序,这就是二叉搜索树的中序遍历的结果,再把二叉搜索树的节点下标按中序遍历输出与前面的元素一一对应就可以获得了二叉搜索树填进去的结果了,最后层序输出就OK了。

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
struct child{
    int left,right;
};
int n,t=0;
vector<child> children(100);
vector<int> a(100),b(100);
void inorder(int index){
    if(children[index].left!=-1)
       inorder(children[index].left);
    b[index]=a[t++];
    if(children[index].right!=-1)
       inorder(children[index].right);
}
int main(){
    int tag=0;
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>children[i].left>>children[i].right;
    for(int i=0;i<n;i++)
        cin>>a[i];
    sort(a.begin(),a.begin()+n);
    inorder(0);
    queue<int> q;
    q.push(0);
    while(!q.empty()){
          int temp=q.front();
          q.pop();
          tag++>0?cout<<" "<<b[temp]:cout<<b[temp];
          if(children[temp].left!=-1)
             q.push(children[temp].left);
          if(children[temp].right!=-1)
             q.push(children[temp].right);
    } 
    return 0;      
}

转载于:https://www.cnblogs.com/A-Little-Nut/p/8430019.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值