poj3071 Football

Description

Consider a single-elimination football tournament involving2n

teams, denoted1,2,,2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n

rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P=[pij]

such that pij

is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n(1n7)

. The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P& will satisfy the constraints that pij=1.0pji for all ij, and pii=0.0 for all i. The end-of-file is denoted by a single line containing the number 1

. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either thedoubledata type instead offloat.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01

.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

概率dp,状态转移方程dp[i][j]=dp[i][j]+dp[i-1][j]*dp[i-1][k]*p[j][k]
表示第j个球队在第i场比赛中获胜的概率
然后枚举和他比赛的k,最后找胜率最高的就是答案了。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
double dp[8][200];
double p[200][200];
int a[9];
int ans;
double step=0;
int main()
{
    ans=0;
    int i,j,k;
    a[1]=2;
    a[0]=1;
    for(i=2;i<=8;i++)
    {
        a[i]=a[i-1]*2;
    }
    int n;
    while(1)
    {
        scanf("%d",&n);
        if(n==-1)
        break;
        memset(dp,0,sizeof(dp));
        for(i=0;i<a[n];i++)
        {
            for(j=0;j<a[n];j++)
            {
                scanf("%lf",&p[i][j]);
            }           
        }
        for(i=0;i<a[n];i++)
        {
            dp[0][i]=1;
        }
        for(i=1;i<=n;i++)
        {
            for(j=0;j<a[n];j++)
            {
                int t=j/a[i-1];
                t^=1;
                dp[i][j]=0;
                for(k=(t*a[i-1]);k<(t*a[i-1]+a[i-1]);k++)
                {
                    dp[i][j]=dp[i][j]+dp[i-1][j]*dp[i-1][k]*p[j][k];
                }    
            }
        }
        step=0;
        for(i=0;i<a[n];i++)
        {
            if(dp[n][i]>step)
            {
                ans=i;
                step=dp[n][i];
            }
        }
        printf("%d\n",ans+1);
    }
}
View Code

 


转载于:https://www.cnblogs.com/ashon37w/p/7066895.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值