高效算法——C 分饼

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input One line with a positive integer: the number of test cases. Then for each test case:

• One line with two integers N and F with 1 ≤ N, F ≤ 10000: the number of pies and the number of friends.

• One line with N integers ri with 1 ≤ ri ≤ 10000: the radii of the pies.

Output For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V .

The answer should be given as a oating point number with an absolute error of at most 10−3 .

Sample Input

3

3 3

3 3

1 24

5

10 5

1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327

3.1416

50.2655

解题思路:这是一个分饼的问题,有n块不同口味的饼,分给F个朋友和自己,每个朋友拿到的饼必须大小一样,而且口味只能有一种,但是是形状可以不一样,求每个朋友能拿到的最大的饼的面积,这个题目有一个高精度问题需要注意,就是pi,要将它定义成acos(-1.0),这样才不会出现误差,用二分法可以逐步实现

程序代码:

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
double pi=acos(-1.0);
double p[10000+10];
double sum,maxn;
int i,n,f,t,k,cnt;
double l,r,m;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
      scanf("%d%d",&n,&f);
      f++;
      l=sum=0;
      for(i=0;i<n;i++)
      {
         scanf("%d",&k);
         p[i]=pi*k*k;
         l=max(p[i],l);
         sum+=p[i];
      }
      l=l/f;
      r=sum/f;
      while(l+0.00001<r)
      {
        m=(l+r)/2;
        cnt=0;
        for(i=0;i<n;i++)
          cnt+=(int)floor(p[i]/m);
        if(cnt<f) r=m;
        else l=m;
      }
      printf("%.4lf\n",l);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/www-cnxcy-com/p/4711665.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值