gdcpc2015A题

题目名称:Article

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5236(在hdu的地址)


Problem Description
As the term is going to end, DRD begins to write his final article.

DRD uses the famous Macrohard's software, World, to write his article. Unfortunately this software is rather unstable, and it always crashes. DRD needs to write  ncharacters in his article. He can press a key to input a character at time  i+0.1, where  i is an integer equal or greater than 0. But at every time  i0.1 for integer  istrictly greater than 0, World might crash with probability  p and DRD loses his work, so he maybe has to restart from his latest saved article. To prevent write it again and again, DRD can press Ctrl-S to save his document at time  i. Due to the strange keyboard DRD uses, to press Ctrl-S he needs to press  x characters. If DRD has input his total article, he has to press Ctrl-S to save the document. 

Since World crashes too often, now he is asking his friend ATM for the optimal strategy to input his article. A strategy is measured by its expectation keys DRD needs to press. 

Note that DRD can press a key at fast enough speed. 
 

Input
First line: an positive integer  0T20 indicating the number of cases.
Next T lines: each line has a positive integer  n105, a positive real  0.1p0.9, and a positive integer  x100.
 

Output
For each test case: output ''Case #k: ans'' (without quotes), where  k is the number of the test cases, and  ans is the expectation of keys of the optimal strategy.
Your answer is considered correct if and only if the absolute error or the relative error is smaller than  106
 

Sample Input
 
   
2 1 0.5 2 2 0.4 2
 

Sample Output
 
   
Case #1: 4.000000 Case #2: 6.444444
 

思路:dp ,用f[i]表示打出前i个字符所用时的数学期望
         转移方程为:f[i] = min (f[j] + g[i-j] + x)
         其中g[i]表示连续打印i个字符不出错的期望
         所以可以推出g[i] =(g[i-1] + 1) * (1 - p) + (g[i-1] + 1 + g[i]) * p ,前半部分求到i不出错的,后面求到i出错的,出错就得重新开始
         所以g[i] = (g[i-1] + 1) / (1 - p)
  不难发现,g的增长速率非常快,故转移时只需考察前面很少的状态

代码如下:
#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=100000+5;
double f[maxn];
int main()
{
    int t,n,x,cnt=0;
    double p;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%lf%d",&n,&p,&x);
        f[0]=0;
        for(int i=1;i<=n;i++)
        {
            double g=1/(1-p);
            f[i]=f[i-1]+g+x;
            for(int j=i-2;j>=0;j--)
            {
                g=(g+1)/(1-p);
                if(g>f[i])
                    break;
                f[i]=min(f[i],f[j]+g+x);
            }
        }
        printf("Case #%d: %.6f\n",++cnt,f[n]);
    }
    return 0;
}





转载于:https://www.cnblogs.com/maplefighting/p/7375705.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值