SDNU 1536.How many users on SDNU OJ(水题)

Description

There are many users on SDNU OJ, but only the one who registered can use it. We think different username represent different user.

One day ZhouXiaohui got a record of "Status Pages", the captain Albert_s wants to know how many users are using SDNU OJ at that time.

He will give you an "Accepted" as a gift if you help him figure out this problem.

Input

The first line of the input contains an integer T, denoting the number of "Status Pages" ZhouXiaohui got.
In each "Status Pages", there is a single integers n in one line, denoting all the username on this pages, then following username .
, ,

Output

For each testcase, print a single line starting with "Case #i:"(i indicates the case number) and then a single integer, denoting the answer Albert_s wants to know, separated with a single space.

Sample Input

1
3
ZhouXiaohui
ZhouLaohui
ZhouXiaohui

Sample Output

Case #1: 2

Source

Unknown
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
using namespace std;
#define ll long long

int t, n, sum;
string name[100000+8];

int main()
{
    scanf("%d", &t);
    int miao = t;
    while(t--)
    {
        bool flag = 0;
        int num = 0;
        cin>>n;
        for(int i = 0; i<n; i++)
        {
            flag = 0;
            cin>>name[i];
            for(int j = 0; j<i; j++)
            {
                if(name[i] == name[j])
                {
                    flag = 1;
                    break;
                }
            }
            if(flag)continue;
            else num++;
        }
        printf("Case #%d: %d\n", miao-t, num);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/RootVount/p/11218141.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值