九度OJ 1146:Flipping Pancake(翻饼子) (递归、游戏)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:265

解决:116

题目描述:

    We start with a stack n of pancakes of distinct sizes. The problem is to convert the stack to one in which the pancakes are in size order with the smallest on the top and the largest on the bottom. To do this, we are allowed to flip the top k pancakes over as a unit (so the k-th pancake is now on top and the pancake previously on top is now in the k-th position).

    For example: This problem is to write a program, which finds a sequence of at most (2n - 3) flips, which converts a given stack of pancakes to a sorted stack. 

输入:

    Each line of the input gives a separate data set as a sequence of numbers separated by spaces. The first number on each line gives the number, N, of pancakes in the data set. The input ends when N is 0 (zero) with no other data on the line. The remainder of the data set are the numbers 1 through N in some order giving the initial pancake stack.

    The numbers indicate the relative sizes of the pancakes. N will be, at most, 30. 

输出:

     For each data set, the output is a single-space separated sequence of numbers on a line. The first number on each line, K, gives the number of flips required to sort the pancakes. This number is followed by a sequence of K numbers, each of which gives the number of pancakes to flip on the corresponding sorting step. There may be several correct solutions for some datasets. For instance 3 3 2 3 is also a solution to the first problem below. 

样例输入:
3 1 3 2
5 4 3 2 5 1
0
样例输出:
3 2 3 2 
3 3 4 5 
来源:
2009年北京大学计算机研究生机试真题

思路:

著名的翻饼子游戏。要求最后状态是小饼在大饼的上面,求翻得次数。最多需要翻2n-3次。

这种题要用逆向思维以及递归方法来分析,考察最终状态及前一步,逐步往前考察,从而发现游戏思路。


代码:

#include <stdio.h>
 
#define N 30
 
int n, k;
int a[N+1], r[N+1], step[2*N+1];
 
void swap(int *x, int *y)
{
    int tmp = *x;
    *x = *y;
    *y = tmp;
}
 
void print(int *x)
{
    int j;
    for (j=1; j<n; j++)
        printf("%d ", x[j]);
    printf("%d\n", x[j]);
}
 
void flip(int i)
{
    int j;
    for (j=1; j<=i/2; j++)
    {
        swap(&a[j], &a[i-j+1]);
        r[a[j]] = j;
        r[a[i-j+1]] = i-j+1;
    }
    step[k++] = i;
    //printf("=====");
    //print(a);
    //print(r);
}
 
int main(void)
{
    int i;
 
    while (scanf("%d", &n) != EOF && n)
    {
        for(i=1; i<=n; i++)
        {
            scanf("%d", &a[i]);
            r[a[i]] = i;
        }
 
        k = 0;
        for (i=n; i>=2; i--)
        {
            if (r[i] != i)
            {
                if (r[i] != 1)
                    flip(r[i]);
                flip(i);
            }
        }
 
        printf("%d ", k);
        for (i=0; i<k-1; i++)
            printf("%d ", step[i]);
        printf("%d\n", step[i]);
 
    }
 
    return 0;
}
/**************************************************************
    Problem: 1146
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/


转载于:https://www.cnblogs.com/liangrx06/p/5083885.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值