Codeforces--626B--Cards(模拟)



Cards

Time Limit: 2000MS

 Memory Limit: 262144KB 64bit IO Format: %I64d & %I64u

Status

Description

Catherine has a deck of n cards, each of which is either red, green, or blue. As long as there are at least two cards left, she can do one of two actions:

  • take any two (not necessarily adjacent) cards with different colors and exchange them for a new card of the third color;
  • take any two (not necessarily adjacent) cards with the same color and exchange them for a new card with that color.

She repeats this process until there is only one card left. What are the possible colors for the final card?

Input

The first line of the input contains a single integer n (1 ≤ n ≤ 200) — the total number of cards.

The next line contains a string s of length n — the colors of the cards. s contains only the characters 'B', 'G', and 'R', representing blue, green, and red, respectively.

Output

Print a single string of up to three characters — the possible colors of the final card (using the same symbols as the input) in alphabetical order.

Sample Input

Input
2
RB
Output
G
Input
3
GRG
Output
BR
Input
5
BBBBB
Output
B

Sample Output

Hint

In the first sample, Catherine has one red card and one blue card, which she must exchange for a green card.

In the second sample, Catherine has two green cards and one red card. She has two options: she can exchange the two green cards for a green card, then exchange the new green card and the red card for a blue card. Alternatively, she can exchange a green and a red card for a blue card, then exchange the blue card and remaining green card for a red card.

In the third sample, Catherine only has blue cards, so she can only exchange them for more blue cards.

Source


如果只有一种颜色,那么只可能生成一种颜色,如果有两种就要分情况了,如果两种颜色各一个,输出的也只能有一种颜色,,,,,,,,

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
char str[10010];
int main()
{
	int n;
	cin>>n;
	cin>>str;
	int R,G,B;
	R=B=G=0;
	for(int i=0;i<n;i++)
	{
		if(str[i]=='R') R++;
		if(str[i]=='G') G++;
		if(str[i]=='B') B++;
	}
	if(R&&G==0&&B==0) cout<<"R"<<endl;
	else if(R==0&&G&&B==0) cout<<"G"<<endl;
	else if(R==0&&G==0&&B) cout<<"B"<<endl;
	else if(R==1&&G==1&&B==0) cout<<"B"<<endl;
	else if(R==1&&G==0&&B==1) cout<<"G"<<endl;
	else if(R==0&&G==1&&B==1) cout<<"R"<<endl;
	
	else if(R==1&&G==0&&B>1) cout<<"GR"<<endl;
	else if(R==1&&G>1&&B==0) cout<<"BR"<<endl;
	else if(R==0&&G==1&&B>1) cout<<"GR"<<endl;
	else if(R==0&&G>1&&B==1) cout<<"BR"<<endl;
	else if(R>1&&G==1&&B==0) cout<<"BG"<<endl;
	else if(R>1&&G==0&&B==1) cout<<"BG"<<endl;
	
	else cout<<"BGR"<<endl;
	return 0;
}

转载于:https://www.cnblogs.com/playboy307/p/5273424.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值