hdu 4864 Task---2014 Multi-University Training Contest 1

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4864


Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1035    Accepted Submission(s): 245


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
 
   
1 2 100 3 100 2 100 1
 

Sample Output
 
   
1 50004
 

Author
FZU
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4871  4869  4868  4867  4866 
 


这是一道贪心的题,要求任务数最多,并且钱也要最多。

那么我们首先先对任务排序,先按时间排序,若时间一样,则依照level排。

之后呢,我们依次选择时间和level最接近该任务的就可以。

因为这道题数据范围比較大,在tle了n次之后,所以我參考了某神牛的博客,採用了set和二分查找进行优化,时间复杂度瞬间就降下来了。。。


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<vector>
#include<set>
#include<map>
#include<bitset>
using namespace std;
typedef long long ll;
const int MAX=100005;
struct Task{
    int x,y;
}t[MAX];
bool cmp(Task a,Task b){if(a.x==b.x) return a.y>b.y;else return a.x>b.x;};
inline ll f(int x,int y){return 500*x+2*y;}
int main(){
    int n,m;
    while(cin>>n>>m){
        multiset<int> st[105];
        int maxlevel=0,cnt=0;
        ll sum=0;
        for(int i=0;i<n;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            st[y].insert(x);
            maxlevel=max(maxlevel,y);
        }
        for(int i=0;i<m;i++){scanf("%d%d",&t[i].x,&t[i].y);}
        sort(t,t+m,cmp);
        for(int i=0;i<m;i++){
            int u=t[i].x,v=t[i].y;
            for(int j=v;j<=maxlevel;j++){
                if(st[j].empty()) continue;
                multiset<int>::iterator it=st[j].lower_bound(u);
                if(it==st[j].end()||*it<u) continue;
                else{
                    cnt++;sum+=f(u,v);
                    st[j].erase(it);
                    break;
                }
            }
        }
        cout<<cnt<<" "<<sum<<endl;
    }
    return 0;
}



转载于:https://www.cnblogs.com/mfrbuaa/p/4172779.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值