hdu3720 Arranging Your Team

Arranging Your Team

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1218    Accepted Submission(s): 360


Problem Description
Your country has qualified for the FIFA 2010 South Africa World Cup. As the coach, you have made up the 23 men squad. Now you must select 11 of them as the starters. As is well known, there are four positions in soccer: goalkeeper, defender, midfielder and striker. Your favorite formation is 4-4-2, that is, you should choose 4 defenders, 4 midfielders, 2 strikers, and of course, 1 goalkeeper. As a retired ACMer, you want to write a program to help you make decision. Each person's ability has been evaluated as a positive integer. And what's more, for some special pairs of persons, if the two people are both on the field, there will be an additional effect (positive or negative). Now you should choose the 11 persons to make the total value maximum.
 

 

Input
There are multiple test cases, separated by an empty line. The first 23 lines of each test case indicate each person's name S i, ability value V i, and position. The length of each name is no more than 30, and there are no whitespaces in the names. All the names are different. The ability values are positive integers and no more than 100. The position is one of "goalkeeper", "defender", "midfielder" and "striker".

Then an integer M indicates that there are M special pairs. Each of the following M lines contains S i, S j and C ij, means that if S i and S j are both on the field, the additional profit is C ij. (-100 ≤ C ij ≤ 100). S i and S j are different strings, and must be in the previous 23 names. All the (S i, S j) pairs
are different.
 

 

Output
Output one line for each test case, indicating the maximum total ability values, that is, the total ability values of the 11 persons plus the additional effects. If you cannot choose a 4-4-2 formation, output "impossible" instead.
 

 

Sample Input
Buffon 90 goalkeeper De_Sanctis 80 goalkeeper Marchetti 80 goalkeeper Zambrotta 90 defender Cannavaro 90 defender Chiellini 90 defender Maggio 90 defender Bonucci 80 defender Criscito 80 defender Bocchetti 80 defender Pirlo 90 midfielder Gattuso 90 midfielder De_Rossi 90 midfielder Montolivo 90 midfielder Camoranesi 80 midfielder Palombo 80 midfielder Marchisio 80 midfielder Pepe 80 midfielder Iaquinta 90 striker Di_Natale 90 striker Gilardino 80 striker Quagliarella 80 striker Pazzini 80 striker 1 Pirlo Quagliarella 50 ZhangSan01 50 goalkeeper ZhangSan02 50 defender ZhangSan03 50 defender ZhangSan04 50 defender ZhangSan05 50 defender ZhangSan06 50 defender ZhangSan07 50 defender ZhangSan08 50 defender ZhangSan09 50 defender ZhangSan10 50 defender ZhangSan11 50 defender ZhangSan12 50 defender ZhangSan13 50 defender ZhangSan14 50 defender ZhangSan15 50 defender ZhangSan16 50 midfielder ZhangSan17 50 midfielder ZhangSan18 50 midfielder ZhangSan19 50 midfielder ZhangSan20 50 midfielder ZhangSan21 50 midfielder ZhangSan22 50 midfielder ZhangSan23 50 midfielder 0
 

 

Sample Output
1030 impossible
 

 

Source
 

 

Recommend
zhouzeyong
 
题意:。。懒得打,身为体育迷一看就懂把。
思路:搜索。适当剪枝即可。
/*
 * Author:  Joshua
 * Created Time:  2014年08月29日 星期五 18时52分48秒
 * File Name: hdu3720.cpp
 */
#include<cstdio>
#include<cstring>
#include<map>
#include<string>
using namespace std;
#define inf 100000000
char s[35],ps[35];
map<string,int> mp;
const int limit[5]={0,1,4,4,2};
int v[25],g[25][25],id[25],cnt[5],t[12],ans;

int gao(char x[])
{
	if (x[0]=='g') return 1;
	if (x[0]=='d') return 2;
	if (x[0]=='m') return 3;
	return 4;
}

void init()
{
	int m,x;
	mp.clear();
	memset(g,0,sizeof(g));
	for (int i=1;i<=23;++i)
	{
		mp[s]=i;
		id[i]=gao(ps);
		if (i<23) scanf("%s%d%s",s,&v[i+1],ps);
	}
	scanf("%d",&m);
	for (int i=1;i<=m;++i)
	{
		scanf("%s%s%d",s,ps,&x);
		g[mp[s]][mp[ps]]=x;
		g[mp[ps]][mp[s]]=x;
	}
}

void updata()
{
	int temp=0;
	for (int i=1;i<=11;++i)
		temp+=v[t[i]];
	for (int i=1;i<=11;++i)
		for (int j=i+1;j<=11;++j)
			temp+=g[t[i]][t[j]];
	if (temp>ans) ans=temp;
}

void dfs(int x,int y)
{
	if (y==11)
	{
		updata();
		return;
	}
	if (x>23) return;
	for (int i=0;i<=1;++i)
	{
		cnt[id[x]]+=i;
		if (cnt[id[x]]<=limit[id[x]]) 
		{   if (i) t[y+1]=x;
			dfs(x+1,y+i);
		}
		cnt[id[x]]-=i;
	}
}

void solve()
{
	memset(cnt,0,sizeof(cnt));
	ans=-inf;
	dfs(1,0);
	if (ans==-inf) printf("impossible\n");
	else printf("%d\n",ans);
}

int main()
{
	while (scanf("%s%d%s",s,&v[1],ps)!=EOF)
	{
		init();
		solve();
	}
	return 0;
}

  

转载于:https://www.cnblogs.com/code-painter/p/3945989.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值