Hdu 2178 猜数字

猜数字

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3415    Accepted Submission(s): 2458


Problem Description
A有1数m,B来猜.B每猜一次,A就说"太大","太小"或"对了" 。 
问B猜n次能够猜到的最大数。 
 

Input
第1行是整数T,表示有T组数据,以下有T行 
每行一个整数n (1 ≤ n ≤ 30) 
 

Output
猜n次能够猜到的最大数
 

Sample Input
 
   
2 1 3
 

Sample Output
 
   
1 7
 


求猜n次最大能猜到的数字,感觉像一种二分的思想,一个数字你要猜到它,最少猜log2(m)+1次就够了,所以在n次之内能猜到的最大数,就是2^n-1

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 100
using namespace std;

int main()
{
    int t,n;
    scanf("%d",&t);

        while(t--)
        {
            scanf("%d",&n);
            printf("%d\n",(int)pow(2,n)-1);
        }

    return 0;
}







转载于:https://www.cnblogs.com/mfrbuaa/p/4301375.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值