Poj 2082 Terrible Sets

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5466 Accepted: 2792
Description


Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑0<=j<=i-1wj <= x <= ∑0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R+ and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.
Input


The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w1h1+w2h2+...+wnhn < 109.
Output


Simply output Max(S) in a single line for each case.
Sample Input


3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1
Sample Output


12

14

题意,找面积最大的矩形,手滑一下点到讨论区,然后就开心的使用单调栈的模版。

#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<map>
#include<iostream>
#include<string.h>
#include<algorithm>
#define maxn 100000
#define maxm 10000005
#define MAXN 100005
#define MAXM 10005
#define mem(a,b) memset(a,b,sizeof(a))
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
int h[maxn+10];
int l[maxn+10],r[maxn+10];
int st[maxn+10];
int sum[maxn+10];
int n;
void solve(){
    int t=0;
    for(int i=0;i<n;i++){
        while(t>0&&h[st[t-1]]>=h[i]) t--;
        l[i]=t==0?0:(st[t-1]+1);
        st[t++]=i;
    }
    t=0;
    for(int i=n-1;i>=0;i--){
        while(t>0&&h[st[t-1]]>=h[i]) t--;
        r[i]=t==0?n:st[t-1];
        st[t++]=i;
    }
    ll res=0;
    for(int i=0;i<n;i++){
        res=max(res,(ll)h[i]*(sum[r[i]]-sum[l[i]]));
    }
    printf("%lld\n",res);
}
int main(){
    while(~scanf("%d",&n)&&n!=-1){
        mem(st,0);mem(h,0);
        mem(l,0);mem(r,0); mem(sum,0);
        for(int i=0;i<n;i++){
            scanf("%d%d",&sum[i+1],&h[i]);
            sum[i+1]+=sum[i];
        }
        solve();
    }
}

转载于:https://www.cnblogs.com/da-mei/p/9053220.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值