hdu4277 暴力

hdu4277   暴力

USACO ORZ

Time Limit : 5000/1500ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 2
Problem Description
Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite.
I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N fence segments and must arrange them into a triangular pasture. Ms. Hei must use all the rails to create three sides of non-zero length. Calculating the number of different kinds of pastures, she can build that enclosed with all fence segments. 
Two pastures look different if at least one side of both pastures has different lengths, and each pasture should not be degeneration.
 

 

Input
The first line is an integer T(T<=15) indicating the number of test cases. The first line of each test case contains an integer N. (1 <= N <= 15) The next line contains N integers li indicating the length of each fence segment. (1 <= li <= 10000)
 

 

Output
For each test case, output one integer indicating the number of different pastures.
 

 

Sample Input
1
3
2 3 4
 
Sample Output
1
 
Source
2012 ACM/ICPC Asia Regional Changchun Online

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<set>

using namespace std;

const int maxn=1000100;

typedef long long ll;
int T;
int a,b,c;
int l[maxn],n;
set<ll> s;

void dfs(int i)
{
    if(i==n+1){
        if(a&&a<=b&&b<=c&&a+b>c){
            if(s.find((a<<16)|b)==s.end()) s.insert((a<<16)|b);
        }
        return;
    }
    a+=l[i];dfs(i+1);a-=l[i];
    b+=l[i];dfs(i+1);b-=l[i];
    c+=l[i];dfs(i+1);c-=l[i];
}

int main()
{
    cin>>T;
    while(T--){
        cin>>n;
        for(int i=1;i<=n;i++) scanf("%d",&l[i]);
        s.clear();
        a=b=c=0;
        dfs(1);
        cout<<(int)s.size()<<endl;
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/--560/p/4782233.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值