zoj 3620 Escape Time II

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4744

Escape Time II

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There is a fire in LTR ’ s home again. The fire can destroy all the things in t seconds, so LTR has to escape in t seconds. But there are some jewels in LTR ’ s rooms, LTR love jewels very much so he wants to take his jewels as many as possible before he goes to the exit. Assume that the ith room has ji jewels. At the beginning LTR is in room s, and the exit is in room e.

Your job is to find a way that LTR can go to the exit in time and take his jewels as many as possible.

Input

There are multiple test cases.
For each test case:
The 1st line contains 3 integers n (2 ≤ n ≤ 10), m, t (1 ≤ t ≤ 1000000) indicating the number of rooms, the number of edges between rooms and the escape time.
The 2nd line contains 2 integers s and e, indicating the starting room and the exit.
The 3rd line contains n integers, the ith interger ji (1 ≤ ji ≤ 1000000) indicating the number of jewels in the ith room.
The next m lines, every line contains 3 integers a, b, c, indicating that there is a way between room a and room b and it will take c (1 ≤ ct) seconds.

Output

For each test cases, you should print one line contains one integer the maximum number of jewels that LTR can take. If LTR can not reach the exit in time then output 0 instead.

Sample Input
3 3 5
0 2
10 10 10
0 1 1 
0 2 2
1 2 3
5 7 9
0 3
10 20 20 30 20
0 1 2
1 3 5
0 3 3
2 3 2
1 2 5
1 4 4
3 4 2
Sample Output
30
80
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxx = 20;
int Edge[maxx][maxx];
int val[maxx];
bool vis[maxx];
int big = 0,e,n,t;
void dfs(int s, int num,int ju)
{
    if(num>t)    return;

    if(s == e)
        if(ju > big && num<=t)
            big = ju;

    vis[s] = true;
    for(int i=0;i<n;i++)
    {
        if(i!=s && Edge[s][i]<1e8 && !vis[i])
        {
            dfs(i,num + Edge[s][i],ju + val[i]);
        }
    }
    vis[s] = false;

}
void Floyd()
{
    for(int i=0; i<n;i++)
        for(int j=0; j<n; j++)
            for(int k=0; k<n; k++)
                if(Edge[j][i] + Edge[i][k] < Edge[j][k])
                    Edge[j][k] = Edge[j][i] + Edge[i][k];
}
int main()
{
      int m;
    int s;
    while(~scanf("%d %d %d",&n,&m,&t))
    {
        memset(Edge,0x6,sizeof(Edge));
        memset(val,0,sizeof(val));
        memset(vis,0,sizeof(vis));
        scanf("%d %d",&s,&e);
        for(int i=0;i<n;i++)
            scanf("%d",&val[i]);
        for(int i=1;i<=m;i++)
        {
            int u,v,w;
            scanf("%d %d %d",&u,&v,&w);
            Edge[u][v] = Edge[v][u] = w;
        }
        Floyd();
        big = 0;
        vis[s] = true;
        dfs(s,0,val[s]);
        printf("%d\n",big);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/cancangood/p/3946203.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值