hdu 1297

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8780    Accepted Submission(s): 2789
Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 
Sample Input
1 2 3
 
Sample Output
1 2 4
大数问题:
规律 f(n)=f(n-1)+f(n-2)+f(n-4)
 
#include<stdio.h>
int a[1001][300];
int main()
{
 int i,j,n,t;
 a[1][0]=1;
 a[2][0]=2;
 a[3][0]=4;
 a[4][0]=7;
 for(i=5;i<=1001;i++)//打表
 {  
 t=0;
  for(j=0;j<300;j++)//表示数的位数  
 {   
 a[i][j]=a[i-1][j]+a[i-2][j]+a[i-4][j]+t;  
  t=0;   
 if(a[i][j]>9)   
 {    
 t=a[i][j]/10;  
   a[i][j]%=10;   
 }  
 } 
 }
 while(scanf("%d",&n)!=EOF)
 {   
 for(i=299;i>=0;i--)//忽略前导的0  
  if(a[n][i])   
  break;  
 for(j=i;j>=0;j--)    
 printf("%d",a[n][j]);  
  printf("\n");
 }  
return 0;
}

转载于:https://www.cnblogs.com/lxm940130740/p/3227949.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值