HDU 5670 Machine 水题

Machine

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5670

Description

There is a machine with m(2≤m≤30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
For any changed bulb,

if it is red now it will be green;

if it is green now it will be blue;

if it is blue now it will be red and the bulb that on the left(if it exists) will change too.

Initally all the bulbs are red. What colour are the bulbs after the button be
pushed n(1≤n<263) times?

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤15) indicating the number of test cases. For each test case:

The only line contains two integers m(2≤m≤30) and n(1≤n<263)

Output

For each test case, output the colour of m bulbs from left to right.
R indicates red. G indicates green. B indicates blue.

Sample Input

2
3 1
2 3

Sample Output

RRG
GR

Hint

题意

有一个机器,它有 \(m (2\leq m\leq 30)\) 个彩灯和一个按钮。每按下按钮时,最右边的彩灯会发生一次变换。变换为:

  1. 如果当前状态为红色,它将变成绿色;

2.如果当前状态为绿色,它将变成蓝色;

3.如果当前状态为蓝色,它将变成红色,并且它左边的彩灯(如果存在)也会发生一次变换。

初始状态下所有的灯都是红色的。
询问按下按钮 \(n (1\leq n< {2}^{63})\) 次以后各个彩灯的颜色。

题解:

其实就是三进制啦

代码

#include<bits/stdc++.h>
using namespace std;
int a[102];
void solve()
{
    int m;long long n;
    scanf("%d%lld",&m,&n);
    for(int i=0;i<m;i++)
    {
        a[i]=n%3;
        n/=3;
    }
    for(int i=m-1;i>=0;i--)
        if(a[i]==0)printf("R");
        else if(a[i]==1)printf("G");
        else printf("B");
    printf("\n");
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)solve();
    return 0;
}

转载于:https://www.cnblogs.com/qscqesze/p/5427121.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值