洛谷 P2910 [USACO08OPEN]寻宝之路Clear And Present Danger

题目描述

Farmer John is on a boat seeking fabled treasure on one of the N (1 <= N <= 100) islands conveniently labeled 1..N in the Cowribbean Sea.

The treasure map tells him that he must travel through a certain sequence A_1, A_2, ..., A_M of M (2 <= M <= 10,000) islands, starting on island 1 and ending on island N before the treasure will appear to him. He can visit these and other islands out of order and even more than once, but his trip must include the A_i sequence in the order specified by the map.

FJ wants to avoid pirates and knows the pirate-danger rating (0 <= danger <= 100,000) between each pair of islands. The total danger rating of his mission is the sum of the danger ratings of all the paths he traverses.

Help Farmer John find the least dangerous route to the treasure that satisfies the treasure map's requirement.

农夫约翰正驾驶一条小艇在牛勒比海上航行.

海上有N(1≤N≤100)个岛屿,用1到N编号.约翰从1号小岛出发,最后到达N号小岛.

一张藏宝图上说,如果他的路程上经过的小岛依次出现了Ai,A2,…,AM(2≤M≤10000)这样的序列(不一定相邻),那他最终就能找到古老的宝藏. 但是,由于牛勒比海有海盗出没.约翰知道任意两个岛屿之间的航线上海盗出没的概率,他用一个危险指数Dij(0≤Dij≤100000)来描述.他希望他的寻宝活动经过的航线危险指数之和最小.那么,在找到宝藏的前提下,这个最小的危险指数是多少呢?

输入输出格式

输入格式:

 

  • Line 1: Two space-separated integers: N and M

  • Lines 2..M+1: Line i+1 describes the i_th island FJ must visit with a single integer: A_i

  • Lines M+2..N+M+1: Line i+M+1 contains N space-separated integers that are the respective danger rating of the path between island i and islands 1, 2, ..., and N, respectively. The ith integer is always zero.

 

输出格式:

 

  • Line 1: The minimum danger that Farmer John can encounter while obtaining the treasure.

 

输入输出样例

输入样例#1:
3 4 
1 
2 
1 
3 
0 5 1 
5 0 2 
1 2 0 
输出样例#1:
7 

说明

There are 3 islands and the treasure map requires Farmer John to visit a sequence of 4 islands in order: island 1, island 2, island 1 again, and finally island 3. The danger ratings of the paths are given: the paths (1, 2); (2, 3); (3, 1) and the reverse paths have danger ratings of 5, 2, and 1, respectively.

He can get the treasure with a total danger of 7 by traveling in the sequence of islands 1, 3, 2, 3, 1, and 3. The cow map's requirement (1, 2, 1, and 3) is satisfied by this route. We avoid the path between islands 1 and 2 because it has a large danger rating.

N<=100 在图上求最小值 多源最短路 故用floyd

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int lx[10000+1],tx[101][101];
int i,j,n,m;
inline int min(int a,int b)
{
    return a>b?b:a; 
}
void FLOYD()
{
    for(int i=0;i<n;++i)
     for(int j=0;j<n;++j)
      for(int k=0;k<n;++k)
        if(tx[j][i]+tx[i][k]<tx[j][k])
         tx[j][k]=tx[i][k]+tx[j][i];
}
int main()
{
    ios::sync_with_stdio(false);
    memset(tx,2,sizeof(tx));
    cin>>n>>m;
    for(i=0;i<m;++i)
    cin>>lx[i];
    int a;
    for(i=0;i<n;++i)
    {
        for(j=0;j<n;++j)
        {
            cin>>a;
            if(i!=j)
            tx[i][j]=min(tx[i][j],a);
        }
    }
    FLOYD();
    int sum=0;
    for(i=0;i<m-1;++i)
    sum+=tx[lx[i]-1][lx[i+1]-1];
    cout<<sum<<endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/ruojisun/p/6379942.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值