hdu 3367 Pseudoforest(最大生成树)

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1705    Accepted Submission(s): 653

Problem Description

In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

Input

The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.

Output

Output the sum of the value of the edges of the maximum pesudoforest.

Sample Input

3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0

Sample Output

3 5

题意:n个点,给你n条边,要求你连一些边,是边权总和最大(整个图可以不连通,对于每个连通子图最多只能有一个环)

 

::按照最大生成树的做法,只要在连接同一个连通子图的两个结点是判断该子图是否已有环,没有才可以连接。

在连接不同连通子图的两个结点是判断两个连通子图的环数之和是否小于2,满足条件就可连接。

 

view code#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
#define REP(i,n) for(int i=0; i<(n); i++)
const int N = 10010;
int n, m, fa[N], num[N];

struct edge
{
    int u, v, w;
    bool operator < (const edge &o) const {
        return w>o.w;
    }
}e[N*10];

int find(int x)
{
    return x==fa[x]?x:(fa[x]=find(fa[x]));
}

void solve()
{
    REP(i,n) fa[i] = i, num[i] = 0;
    REP(i,m) scanf("%d%d%d", &e[i].u, &e[i].v, &e[i].w);
    sort(e, e+m);
    int ans = 0;
    REP(i, m)
    {
        int u = find(e[i].u), v =find(e[i].v);
        if(u==v && num[v]==0)
            ans += e[i].w, num[v]++;
        else if(u!=v && num[v]+num[u]<2)
            fa[u] = v, num[v]+= num[u], ans += e[i].w;
    }
    printf("%d\n", ans);
}

int main()
{
//    freopen("in.txt", "r", stdin);
    while(cin>>n>>m &&(n|m) ) solve();
    return 0;
}

转载于:https://www.cnblogs.com/zyx1314/p/3877202.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值