PAT 甲级 1022 Digital Library (30 分)(字符串读入getline,istringstream,测试点2时间坑点)...

1022 Digital Library (30 分)
 

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题解:
题意是一个图书馆查询系统,除了第三个查询是查找子串,其他的问题都是字符串比较,所以就用了循环。
1.keywords的读入用到了一个字符串流
istringstream tmp(str);//<sstream>以空格分开字符串 
a[i].kn=0;
while(tmp>>word)
{
    a[i].kn++;
    a[i].key[a[i].kn]=word;
}
也可以
while(cin>>string){
char c = getchar()
if(c == ‘\n’) break;
}
2.题目中所说的year在[1000, 3000]之间,但是所给的测试并不一定在这之间,否则会测试点2不能通过。

AC代码:
#include<bits/stdc++.h>
using namespace std;
struct node{
    int id;
    string ti;
    string au;
    int kn;
    string key[15];
    string pu;
    string year;//测试点2坑点,用int反而错了,year不一定全在[1000, 3000]之间 
    
}a[10005];
bool cmp(node x,node y){
    return x.id<y.id;
}
int main(){
    int n;
    cin>>n;    
    string str,word;
    for(int i=1;i<=n;i++){ 
        cin>>a[i].id;
        getchar();//吸收回车
        getline(cin,a[i].ti);
        getline(cin,a[i].au);
        
        getline(cin,str);
        istringstream tmp(str);//<sstream>以空格分开字符串 
        a[i].kn=0;
        while(tmp>>word)
        {
            a[i].kn++;
            a[i].key[a[i].kn]=word;
        }
        
        getline(cin,a[i].pu);
        getline(cin,a[i].year);
    }
    /*cout<<endl;
    for(int i=1;i<=n;i++){
        cout<<"ID "<<a[i].id<<endl;
        cout<<"TI "<<a[i].ti<<endl;
        cout<<"AU "<<a[i].au<<endl;
        for(int j=1;j<=a[i].kn;j++){
            cout<<a[i].key[j]<<"-";
        }
        cout<<endl;
        cout<<"PU "<<a[i].pu<<endl;
        cout<<"YE "<<a[i].year<<endl;
    }*/
    sort(a+1,a+1+n,cmp);
    int m; 
    cin>>m;
    int k;
    char kk;
    string find;
    for(int i=1;i<=m;i++){
        cin>>k;
        cin>>kk;//冒号 
        getchar();//空格     
        getline(cin,find);
        cout<<k<<": "<<find<<endl;        
        int f=0;
        if(k==1){//ti 
            for(int j=1;j<=n;j++){
                if(a[j].ti==find){
                    f=1;
                    printf("%07d\n", a[j].id);
                }
            }
        }else if(k==2){//au
            for(int j=1;j<=n;j++){
                if(a[j].au==find){
                    f=1;
                    printf("%07d\n", a[j].id);
                }
            }    
        }else if(k==3){//kw
            for(int j=1;j<=n;j++){
                for(int p=1;p<=a[j].kn;p++){
                    if(a[j].key[p]==find){
                        f=1;
                        printf("%07d\n", a[j].id);
                        break;
                    }                
                }    
            }
        }else if(k==4){//pu
            for(int j=1;j<=n;j++){
                if(a[j].pu==find){
                    f=1;
                    printf("%07d\n", a[j].id);
                }
            }
        }else if(k==5){//year
            for(int j=1;j<=n;j++){
                if(a[j].year==find){
                    f=1;
                    printf("%07d\n", a[j].id);
                }
            }
        }    
        if(!f){
            cout<<"Not Found"<<endl;
        }
    }
    return 0;
} 
 
    

 



 

转载于:https://www.cnblogs.com/caiyishuai/p/11340382.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值