HDOJ 2473 HDU 2473 Junk-Mail Filter ACM 2473 IN HDU

MiYu原创, 转帖请注明 : 转载自 ______________白白の屋    

 

题目地址:

      http://acm.hdu.edu.cn/showproblem.php?pid=2473 

题目描述:

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1785    Accepted Submission(s): 521


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
 
    
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
 
    
Case #1: 3 Case #2: 2
 

题目分析:

       题目的意思大概就是 有N 封邮件, 编号 0 -> N-1,  然后有2种操作,  M : 合并操作, 将 2 种邮件合并为一种.

                                                                                                                          S  : 分离操作, 将一封邮件独立出去, 单独占一个集合.

      最后题目要求统计 集合的 个数.   从这里可以很容易的看出, 这是一个 并查集的题目, 不过按朴素方法来做的话, 一般都会 TLE.

加上数据量很大 ,  不要使用 cin , 会超时. 而且一般来说 G ++ 和 C++ 在处理大量数据的时候会有1倍的时差 !!! 所以一般建议使用

C++ 提交代码.

 

 先看代码 :

 /*

MiYu原创, 转帖请注明 : 转载自 ______________白白の屋

          http://www.cnblog.com/MiYu

Author By : MiYu

Test      : 1

Program   : 2473

*/


#include <iostream>

#include <algorithm>

using namespace std;

int set[1350005];

int a[125000];

int N,M;

int inline find ( int x )

{

    return x != set[x] ? set[x] = find ( set[x] ) : set[x]; 

void inline merge ( int x, int y )

{

     x = find ( x );

     y = find ( y );

     if ( x == y )  return ;

     set[x] = y; 

}

int main ()

{

    int ca = 1;

    while ( scanf ( "%d%d",&N,&M ), M || N )

    {

            for ( int i = 0; i < N; ++ i )

                  set[i] = i+N;

            for ( int i = N; i <= N + N + M; ++ i )

                  set[i] = i;          //       <------------------------------这是关键, 虽然空间的消耗比较大, 但是节省了大量时间, 这样处理的目的是将0 -> N-1 的 节点处理成叶子节点

                                         //                                                       这样在对这些 节点做 S 操作的时候就不会影响到其他的节点, 而 find 操作是带路径压缩的, 所以就保证了我们所                                            //                                                       有要处理的节点一直是叶子节点 !!!

            int sep = N + N;

            int x,y; char ch[5]; 

            for ( int i = 0; i != M; ++ i )

            {

                  scanf ( "%s",ch ); 

                  switch ( ch[0] )

                  {

                           case 'M': scanf ( "%d%d",&x,&y ); merge ( x,y ); break;

                           case 'S': scanf ( "%d",&x ); set[x] = sep ++;    break;                   //初始化操作就是为这一步准备的

                  }

            } 

            for ( int i = 0; i != N; ++ i )

                  a[i] = find ( i );

            sort ( a, a + N );   

            int nCount = 1;

            for ( int i = 1; i < N; ++ i )

                  if ( a[i] != a[i-1] ) nCount ++;

            printf("Case #%d: %d\n",ca++,nCount);

    }

    return 0;

}


 

 

转载于:https://www.cnblogs.com/MiYu/archive/2010/08/26/1808750.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值