HDU 3652 —— B-number

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 

Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output

Print each answer in a single line.
 

Sample Input

13
100
200
1000
 

Sample Output

1
1
2
2
 
    当我们没有限制,可以任意填写数字时(limit=0),如果剩下的等待填写的位数(u)相同,上一位是否为1 (is1)相同,之前是否出现13(have)相同,之前填写的数字 模13的结果也相同,则可以断定:即使我之前填写的数字是不一样的,最终填写完全后,含有13且模13等于0的数字个数会是相同的!  (注意:这里涉及到“大整数取模”的背景知识)
    因此,dp[u][is1][have][mod]的定义是m满足“无后效性”。
#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

int len;
int a[12], b[12];
int dp[12][2][2][13];

int dfs(int u, bool is1, bool have, int mod, bool limit)
{
    if(u < 1)    return have && mod ==0;
    
    if(!limit && dp[u][is1][have][mod] != -1)    return dp[u][is1][have][mod];
    
    int maxn = limit ? a[u] : 9;
    int ret = 0;
    
    for(int i=0; i<=maxn; i++) {
        b[u] = i;
        ret += dfs(u-1, i==1, have||is1&&i==3, (mod*10%13+i)%13, limit&&i==maxn);
    }
    if(!limit)    dp[u][is1][have][mod] = ret;
    return ret;
}

int f(int n)
{
    len=0;
    while(n) {
        a[++len] = n%10;
        n /= 10;
    }
    return dfs(len, 0, 0, 0, 1);
}

int main ()
{
    int n;
    memset(dp, -1, sizeof(dp));
    while(scanf("%d", &n) != EOF) {
        printf("%d\n", f(n));
    }
    
    return 0;
}

 

转载于:https://www.cnblogs.com/AcIsFun/p/5389532.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值