POJ_3624Charm Bracelet(01背包)

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15410 Accepted: 7028

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

做的0,1背包问题第一题,详解看《背包九讲》。

因为:3405 * 12885 * 4 / 1024 =  171380  > 65536,栈溢出,所以只能将二维的转化为一维来解决。

二维:

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
typedef struct Point
{
	int w;
	int d;
}Point;
Point point[3405];
int dp[3405][12885];
int n, m;

void DP()  
{  
	for(int i = 1; i <= n; i++)
	{
		for(int v = 0; v <= m; v++)
		{
			if(v >= point[i].w)
			{
				dp[i][v] = max(dp[i-1][v], dp[i-1][v-point[i].w] + point[i].d);
			}
			else
			{
				dp[i][v] = dp[i-1][v];
			}
		}
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	int x, y;
	cin >> n >> m;
	int count = 1;
	for(int i = 1; i <= n; i++)
	{
		cin >> x >> y;
		point[count].w = x;
		point[count++].d = y;
	}
	memset(dp, 0, sizeof(dp));
	DP();
	cout << dp[n][m] << endl;
	return 0;
}


一维:


#include<iostream>
#include<cstdio>
#include<map>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
#include<set>
#include<string>
#include<queue>
#include <stack>
#define inf 1<<28
const int MAXN=200010;
#define pb(x) push_back(x)
#define mem(x,y) memset(x,y,sizeof(x))
#define LL long long
using namespace std;

typedef struct Point
{
	int w;
	int d;
}Point;

int main()
{
	freopen("in.txt", "r", stdin);
	Point point[3405];
	int dp[12885] = {0};
	int n, m, x, y;
	cin >> n >> m;
	for(int i = 1; i <= n; i++)
	{
		cin >> x >> y;
		point[i].w = x;
		point[i].d = y;
	}
	for(int i = 1; i <= n; i++)
	{
		for(int v = m; v >= point[i].w; v--)
		{
		         dp[v] = max(dp[v], dp[v-point[i].w ]+ point[i].d);
		}
	}
	cout << dp[m] << endl; 
}




转载于:https://www.cnblogs.com/lgh1992314/archive/2013/04/11/5835133.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值