hdu-5895 Mathematician QSC(数学)

题目链接:

Mathematician QSC

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 189    Accepted Submission(s): 90


Problem Description
QSC dream of becoming a mathematician, he believes that everything in this world has a mathematical law.

Through unremitting efforts, one day he finally found the QSC sequence, it is a very magical sequence, can be calculated by a series of calculations to predict the results of a course of a semester of a student.

This sequence is such like that, first of all, f(0)=0,f(1)=1,f(n)=f(n2)+2f(n1)(n2)Then the definition of the QSC sequence is g(n)=ni=0f(i)2. If we know the birthday of the student is n, the year at the beginning of the semester is y, the course number x and the course total score s, then the forecast mark is xg(ny)%(s+1).
QSC sequence published caused a sensation, after a number of students to find out the results of the prediction is very accurate, the shortcoming is the complex calculation. As clever as you are, can you write a program to predict the mark?
 

 

Input
First line is an integer T(1≤T≤1000).

The next T lines were given n, y, x, s, respectively.

n、x is 8 bits decimal integer, for example, 00001234.

y is 4 bits decimal integer, for example, 1234.
n、x、y are not negetive.

1≤s≤100000000
 

 

Output
For each test case the output is only one integer number ans in a line.
 

 

Sample Input
2
20160830 2016 12345678 666
20101010 2014 03030303 333
 

 

Sample Output
1
317
 
题意:
 
求上面那个式子的值;
 
思路:
 
难点在怎么推出g[n]的表达式了;g(n)=f(n)*f(n+1)/2;
 
f(n)=f(n-2)+2*f(n-1)
f(n)*f(n-1)=f(n-2)*f(n-1)+2*f(n-1)*f(n-1);
2*f(n-1)*f(n-1)=f(n)*f(n-1)-f(n-2)*f(n-1);
连加得到g(n)=f(n)*f(n+1)/2;
然后就是矩阵快速幂和指数循环节的套路了;
 
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <bits/stdc++.h>
#include <stack>
#include <map>
  
using namespace std;
  
#define For(i,j,n) for(int i=j;i<=n;i++)
#define mst(ss,b) memset(ss,b,sizeof(ss));
  
typedef  long long LL;
  
template<class T> void read(T&num) {
    char CH; bool F=false;
    for(CH=getchar();CH<'0'||CH>'9';F= CH=='-',CH=getchar());
    for(num=0;CH>='0'&&CH<='9';num=num*10+CH-'0',CH=getchar());
    F && (num=-num);
}
int stk[70], tp;
template<class T> inline void print(T p) {
    if(!p) { puts("0"); return; }
    while(p) stk[++ tp] = p%10, p/=10;
    while(tp) putchar(stk[tp--] + '0');
    putchar('\n');
}
  
//const LL mod=1e9+7;
const double PI=acos(-1.0);
const LL inf=1e18;
const int N=(1<<20)+10;
const int maxn=1e5+10;
const double eps=1e-12;
 
LL prime[maxn],mod;
int vis[maxn],cnt=0;
struct matrix 
{
    LL a[2][2];
};
matrix cal(matrix A,matrix B)
{
    matrix C;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<=2;j++)
        {
            C.a[i][j]=0;
            for(int k=0;k<2;k++)
            {
                C.a[i][j]+=A.a[i][k]*B.a[k][j];
                C.a[i][j]%=mod;
            }
        }
    }
    return C;
}

LL pow_mod(LL y)
{
    if(y==0)return 0;
    else if(y==1)return 1;
    else if(y==2)return 2;
    else y-=2;
    matrix s,base;
    s.a[0][0]=s.a[1][1]=1;s.a[0][1]=s.a[1][0]=0;
    base.a[0][0]=2,base.a[0][1]=base.a[1][0]=1,base.a[1][1]=0;
    while(y)
    {
        if(y&1)s=cal(s,base);
        base=cal(base,base);
        y>>=1;
    }
    return (s.a[0][0]*2+s.a[0][1])%mod;
}
inline void Init()
{
    for(int i=2;i<maxn;i++)
    {
        if(!vis[i])
        {
            for(int j=2*i;j<maxn;j+=i)vis[j]=1;
            prime[++cnt]=(LL)i;
        }
    }
}
LL phi(LL fx)
{
    LL s=fx;
    for(int i=1;i<=cnt;i++)
    {
        if(fx<prime[i])break;
        if(fx%prime[i]==0)
        {
            s=s/prime[i]*(prime[i]-1);
            while(fx%prime[i]==0)fx/=prime[i];
        }
    }
    if(fx>1)s=s/fx*(fx-1);
    return s;
}
LL powmod(LL a,LL b,LL mo)
{
  LL s=1,base=a;
  while(b)
  {
    if(b&1)s=s*base%mo;
    base=base*base%mo;
    b>>=1;
  }
  return s;
}
int main()
{
    Init();
    int t;
    LL n,y,x,s;
    read(t);
    while(t--)
    {
        scanf("%lld%lld%lld%lld",&n,&y,&x,&s);
        s++;
        mod=phi(s)*2;
        LL ans=pow_mod(n*y)*pow_mod(n*y+1)%mod/2+mod/2;
        ans=powmod(x,ans,s);
        printf("%lld\n",ans);
    }
    return 0;
}

  

 

转载于:https://www.cnblogs.com/zhangchengc919/p/5886051.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于微信小程序的家政服务预约系统采用PHP语言和微信小程序技术,数据库采用Mysql,运行软件为微信开发者工具。本系统实现了管理员和客户、员工三个角色的功能。管理员的功能为客户管理、员工管理、家政服务管理、服务预约管理、员工风采管理、客户需求管理、接单管理等。客户的功能为查看家政服务进行预约和发布自己的需求以及管理预约信息和接单信息等。员工可以查看预约信息和进行接单。本系统实现了网上预约家政服务的流程化管理,可以帮助工作人员的管理工作和帮助客户查询家政服务的相关信息,改变了客户找家政服务的方式,提高了预约家政服务的效率。 本系统是针对网上预约家政服务开发的工作管理系统,包括到所有的工作内容。可以使网上预约家政服务的工作合理化和流程化。本系统包括手机端设计和电脑端设计,有界面和数据库。本系统的使用角色分为管理员和客户、员工三个身份。管理员可以管理系统里的所有信息。员工可以发布服务信息和查询客户的需求进行接单。客户可以发布需求和预约家政服务以及管理预约信息、接单信息。 本功能可以实现家政服务信息的查询和删除,管理员添加家政服务信息功能填写正确的信息就可以实现家政服务信息的添加,点击家政服务信息管理功能可以看到基于微信小程序的家政服务预约系统里所有家政服务的信息,在添加家政服务信息的界面里需要填写标题信息,当信息填写不正确就会造成家政服务信息添加失败。员工风采信息可以使客户更好的了解员工。员工风采信息管理的流程为,管理员点击员工风采信息管理功能,查看员工风采信息,点击员工风采信息添加功能,输入员工风采信息然后点击提交按钮就可以完成员工风采信息的添加。客户需求信息关系着客户的家政服务预约,管理员可以查询和修改客户需求信息,还可以查看客户需求的添加时间。接单信息属于本系统里的核心数据,管理员可以对接单的信息进行查询。本功能设计的目的可以使家政服务进行及时的安排。管理员可以查询员工信息,可以进行修改删除。 客户可以查看自己的预约和修改自己的资料并发布需求以及管理接单信息等。 在首页里可以看到管理员添加和管理的信息,客户可以在首页里进行家政服务的预约和公司介绍信息的了解。 员工可以查询客户需求进行接单以及管理家政服务信息和留言信息、收藏信息等。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值