Fermat’s Chirstmas Theorem (素数打表的)

                                                                         Fermat’s Chirstmas Theorem
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

In a letter dated December 25, 1640; the great mathematician Pierre de Fermat wrote to Marin Mersenne that he just proved that an odd prime p is expressible as p = a2 + b2 if and only if p is expressible as p = 4c + 1. As usual, Fermat didn’t include the proof, and as far as we know, never
wrote it down. It wasn’t until 100 years later that no one other than Euler proved this theorem.

Input

Your program will be tested on one or more test cases. Each test case is specified on a separate input line that specifies two integers L, U where L ≤ U < 1, 000, 000
The last line of the input file includes a dummy test case with both L = U = −1.

Output

L U x y
where L and U are as specified in the input. x is the total number of primes within the interval [L, U ] (inclusive,) and y is the total number of primes (also within [L, U ]) that can be expressed as a sum of squares.

Sample Input

10 20
11 19
100 1000
-1 -1

Sample Output

10 20 4 2
11 19 4 2
100 1000 143 69
#include<stdio.h>  
#include<string.h>  

#define N 1000005

int prime[100005];  
int flag[1000005];  
int e;
  
void getP()  // 素数打表,找出素数存栈  
{  
	int i, j;  
	e = 0;  
	memset(flag, 0, sizeof(flag) ); //标记初始化
	
	for ( i=2; i<N; i++)  
	{  
		if ( flag[i]==0 ) 
		{
			prime[e++] = i; //进栈  
		}
		for ( j=0; j<e && i*prime[j]<N; j++ )  
		{  
			flag[ i * prime[j] ] = 1;  
		}  
	}  
}  

int main()  
{  
	int l,u,x,y;  

	getP(); 
	int i;
	while(scanf("%d %d",&l,&u))  
	{  
	  
		if(l==-1 && u==-1)  
            break;  
		x=0;  
		y=0;
		for( i=0; i<e; i++)  
		{  
			if(prime[i]>=l && prime[i]<=u )  
			{  
				x++;  
				if(prime[i]%4==1) 
				{
                    y++;  
				}
			}  
			if(prime[i]>u)  
                break;  
		}  
		if(l<=2 && u>=2)
		{
			y++;
		}
		printf("%d %d %d %d\n",l, u, x, y );  
	}  
	return 0;  
}  

 

转载于:https://www.cnblogs.com/yspworld/p/3900513.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值