浙江大学Pat 1036 题解

1036. Boys vs Girls (25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

 

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA

题解:

#include"iostream"
#include "string"
#include<vector>
#include"algorithm"
#include "cmath"
using namespace std;

struct Student
{
string name;
char gender;
string id;
int grade;
};

bool malecmp(Student a, Student b)
{
return a.grade < b.grade;
}
bool femalecmp(Student a, Student b)
{
return a.grade > b.grade;
}
int main()
{
vector<Student> male;
vector<Student> female;
Student stu;
int num;
cin>>num;
for(int i=0;i<num;i++)
{
cin >> stu.name >> stu.gender >> stu.id >> stu.grade;
if(stu.gender == 'M')
male.push_back(stu);
else
female.push_back(stu);
}
sort(male.begin(),male.end(),malecmp);
sort(female.begin(),female.end(),femalecmp);
vector<Student>::iterator mit = male.begin();
vector<Student>::iterator fmit = female.begin();
if(fmit!=female.end())
{
cout<<(*fmit).name<<" "<<(*fmit).id<<endl;
}
else
cout<<"Absent"<<endl;
if(mit!=male.end())
{
cout<<(*mit).name<<" "<<(*mit).id<<endl;
}
else
cout<<"Absent"<<endl;
if(fmit==female.end()||mit==male.end())
cout<<"NA"<<endl;
else
cout<<(*fmit).grade-(*mit).grade<<endl;
return 0;
}

 





转载于:https://www.cnblogs.com/luxiao/p/pat1036.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值