快速切题 sgu120. Archipelago 计算几何

120. Archipelago

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

 

Archipelago Ber-Islands consists of N islands that are vertices of equiangular and equilateral N-gon. Islands are clockwise numerated. Coordinates of island N1 are (x1, y1), and island N2 – (x2, y2). Your task is to find coordinates of all N islands.

 

Input

In the first line of input there are N, N1 and N2 (3£ N£ 150, 1£ N1,N2£N, N1¹N2separated by spaces. On the next two lines of input there are coordinates of island N1 and N2 (one pair per line) with accuracy 4digits after decimal point. Each coordinate is more than -2000000 and less than 2000000.

 

Output

Write N lines with coordinates for every island. Write coordinates in order of island numeration. Write answer with 6 digits after decimal point.

 

Sample Input

4 1 3
1.0000 0.0000
1.0000 2.0000

Sample Output

1.000000 0.000000
0.000000 1.000000
1.000000 2.000000
2.000000 1.000000

思路:首先旋转N1N2一定角度到圆心方向利用三角形求出圆心O,然后旋转oN1得到其他点

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=150;
const double eps=1e-12;
const double pie=acos(-1);
double xo,yo;
double x[maxn],y[maxn];
int n,n1,n2;
typedef pair<double,double> P;
P rot(double x,double y,double angle){
    P p1;
    p1.first=y*sin(angle)+x*cos(angle);
    p1.second=y*cos(angle)-x*sin(angle);
    return p1;
}
int main(){
    scanf("%d%d%d",&n,&n1,&n2);n1--;n2--;
    scanf("%lf%lf%lf%lf",x+n1,y+n1,x+n2,y+n2);
    if(n1>n2)swap(n1,n2);
    P p1=P(x[n2]-x[n1],y[n2]-y[n1]);
    int gap=n2-n1;
    double angle=pie/n*gap;
    double angle2=pie/2-angle;if(angle<eps)angle+=pie;//取夹角不可能钝角或<0
    p1=rot(p1.first,p1.second,angle2);
    p1.first=-p1.first/2/cos(angle2);
    p1.second=-p1.second/2/cos(angle2);
    xo=-p1.first+x[n1],yo=-p1.second+y[n1];
    for(int i=(n1+1)%n;i!=n1;i=(i+1)%n){
        p1=rot(p1.first,p1.second,2*pie/n);
        x[i]=p1.first+xo;
        y[i]=p1.second+yo;
    }
    for(int i=0;i<n;i++){
        printf("%.6f %.6f\n",x[i],y[i]);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/xuesu/p/4005598.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值