POJ 2553 The Bottom of a Graph (Tarjan)

                       The Bottom of a Graph
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11981 Accepted: 4931

Description

We will use the following (standard) definitions from graph theory. Let  V be a nonempty and finite set, its elements being called vertices (or nodes). Let  E be a subset of the Cartesian product  V×V, its elements being called edges. Then  G=(V,E) is called a directed graph. 
Let  n be a positive integer, and let  p=(e1,...,en) be a sequence of length  n of edges  ei∈E such that  ei=(vi,vi+1) for a sequence of vertices  (v1,...,vn+1). Then  p is called a path from vertex  v1to vertex  vn+1 in  G and we say that  vn+1 is reachable from  v1, writing  (v1→vn+1)
Here are some new definitions. A node  v in a graph  G=(V,E) is called a sink, if for every node  w in  G that is reachable from  vv is also reachable from  w. The bottom of a graph is the subset of all nodes that are sinks, i.e.,  bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph  G. Each test case starts with an integer number  v, denoting the number of vertices of  G=(V,E), where the vertices will be identified by the integer numbers in the set  V={1,...,v}. You may assume that  1<=v<=5000. That is followed by a non-negative integer  e and, thereafter,  e pairs of vertex identifiers  v1,w1,...,ve,we with the meaning that  (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

 思路:

终于过了。。。。

因为模板错误,让我痛不欲生。

这题完成缩点之后,找出没有出度的点就行了。

http://www.cnblogs.com/ZGQblogs/p/9104381.html

我的模板会在此更新,感谢感谢!

我的上一篇博客里面的代码(POJ 1236)的确是错的,这个里面的代码应该就没问题了。。

代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<stack>
#include<cstring>
using namespace std;
int n,m;
int book[50008];
int low[50008],num[50008],cnt=1,index;
int color[50008];
bool flag[50008];
vector<int>u[50008];
stack<int>st;
int sig=0;
void Tarjan(int t)
{
    num[t]=low[t]=++index;
    st.push(t);
    book[t]=true;
    int siz=u[t].size();
    for(int i=0;i<siz;i++){
        if(!num[u[t][i]]){
            Tarjan(u[t][i]);
            low[t]=min(low[t],low[u[t][i]]);
        }
        else if(book[u[t][i]]){low[t]=min(low[t],low[u[t][i]]);}
    }

    if(num[t]==low[t]){
        sig++;
        while(1){

            cnt=st.top();
            st.pop();
            color[cnt]=sig;
            book[cnt]=0;
            if(cnt==t){break;}
        }
    }
}


bool init()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        u[i].clear();
    }
    while(!st.empty()){
        st.pop();
    }
    memset(book,0,sizeof(book));
    memset(low,0,sizeof(low));
    memset(flag,0,sizeof(flag));
    memset(color,0,sizeof(color));
    memset(num,0,sizeof(num));
    index=0;
    if(n==0){return false;}
    scanf("%d",&m);
    int x,y;
    for(int i=1;i<=m;i++){
        scanf("%d%d",&x,&y);
        u[x].push_back(y);
    }
    return true;
}


void solve()
{
    int siz;
    int tle=0;
    for(int i=1;i<=n;i++){
        siz=u[i].size();
        for(int j=0;j<siz;j++){
            if(color[u[i][j]]!=color[i]){flag[color[i]]=true;}
        }
    }

    for(int i=1;i<=n;i++){
        if(!flag[color[i]]){
            tle++?printf(" %d",i):printf("%d",i);
        }
    }
    printf("\n");
}

int main()
{
    while(init()){
        for(int i=1;i<=n;i++){
            if(!num[i]){Tarjan(i);cnt++;}
        }
        solve();
    }
}

  

 

转载于:https://www.cnblogs.com/ZGQblogs/p/9395337.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值