hdu 5532 Almost Sorted Array nlogn 的最长非严格单调子序列

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2504    Accepted Submission(s): 616


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,,an, is it almost sorted?
 

 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,,an.

1T2000
2n105
1ai105
There are at most 20 test cases with n>1000.
 

 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 

 

Sample Output
YES YES NO
 

 

Source
 

 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5780 5779 5778 5777 5776 
题意:依次给你n个数字,判断其是否是至少>=n-1长的单调子序列;
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
typedef  long long  ll;
typedef unsigned long long ull;
#define MM(a,b) memset(a,b,sizeof(a));
#define inf 0x7f7f7f7f
#define FOR(i,n) for(int i=1;i<=n;i++)
#define CT continue;
#define PF printf
#define SC scanf
const int mod=1000000007;
const int N=100000+10;
ull seed=13331;

int dp[N],ans[N],a[N];
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--){
       int n;scanf("%d",&n);
       for(int i=1;i<=n;i++) scanf("%d",&a[i]);
       int len=1,flag1=0,flag2=0;
       ans[1]=a[1];
       for(int i=2;i<=n;i++)
       {
             if(a[i]>=ans[len]) {len++;ans[len]=a[i];}
             else{
                int pos=upper_bound(ans+1,ans+len,a[i])-ans;
                ans[pos]=a[i];
             }
       }
       if(len>=n-1) flag1=1;
       len=1;ans[1]=a[n];
       for(int i=n-1;i>=1;i--)
       {
             if(a[i]>=ans[len]) {len++;ans[len]=a[i];}
             else{
                int pos=upper_bound(ans+1,ans+len,a[i])-ans;
                ans[pos]=a[i];
             }
       }
       if(len>=n-1) flag2=1;
       if(flag1||flag2) printf("YES\n");
       else printf("NO\n");
    }
    return 0;
}

  分析:严格单调递增子序列就是lower_bound(),直接进行替换;非严格单调子序列就是upper_bound();

 if(a[i]>=ans[len]) {len++;ans[len]=a[i];}
             else{
                int pos=upper_bound(ans+1,ans+len,a[i])-ans;//非严格单调
                ans[pos]=a[i];
             }

  

转载于:https://www.cnblogs.com/smilesundream/p/5727628.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值