HDU 2103 Family planning

http://acm.hdu.edu.cn/showproblem.php?pid=2103

 

Problem Description
As far as we known,there are so many people in this world,expecially in china.But many people like LJ always insist on that more people more power.And he often says he will burn as much babies as he could.Unfortunatly,the president XiaoHu already found LJ's extreme mind,so he have to publish a policy to control the population from keep on growing.According the fact that there are much more men than women,and some parents are rich and well educated,so the president XiaoHu made a family planning policy:
According to every parents conditions to establish a number M which means that parents can born M children at most.But once borned a boy them can't born other babies any more.If anyone break the policy will punished for 10000RMB for the first time ,and twice for the next time.For example,if LJ only allowed to born 3 babies at most,but his first baby is a boy ,but he keep on borning another 3 babies, so he will be punished for 70000RMB(10000+20000+40000) totaly.
 
Input
The first line of the input contains an integer T(1 <= T <= 100) which means the number of test cases.In every case first input two integers M(0<=M<=30) and N(0<=N<=30),N represent the number of babies a couple borned,then in the follow line are N binary numbers,0 represent girl,and 1 represent boy.
 
Output
Foreach test case you should output the total money a couple have to pay for their babies.
 
Sample Input
2
2 5
0 0 1 1 1
2 2
0 0
 
Sample Output
70000 RMB
0 RMB
 
代码:
#include <bits/stdc++.h>
using namespace std;

int a[50];

int main() {
    int T;
    scanf("%d", &T);
    for(int i = 1; i <= T; i ++) {
        int temp = 0;
        int n, m, k;
        scanf("%d%d", &m, &n);
        double sum = 0;
        for(int j = 1; j <= n; j ++)
            scanf("%d", &a[j]);

        for(int j = 1; j <= n; j ++) {
            if(a[j] == 1) {
                temp = j;
                break;
            }
        }

        if(n <= m) {
            if(temp == 0 || temp == n) {
                printf("0 RMB\n");
                continue;
            }
            else
                k = n - temp - 1;
        }
        else {
            if(temp == 0)
                k = n - m - 1;
            else {
                if(temp > m)
                    k = n - m - 1;
                else
                    k = n - temp -1;
            }
        }

        for(int j = 0; j <= k; j ++)
            sum += pow(2.0, j  * 1.0);
        sum = sum * 10000;
        printf("%.0lf RMB\n", sum);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/zlrrrr/p/9410878.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值