ZOJ 3927 Programming Ability Test

Programming Ability Test (PAT) aims to evaluate objectively, through unified examinations with automatic online judging system, the abilities of testees in programming and algorithm design, hence to evaluate scientifically the programming talents, and to provide the enterprises a reference standard for personnel selection.

The alliance enterprises may have their specific green channel preferential conditions listed at the PAT registration website. Some enterprises also provide “Letter of Introduction” for the testees to download and submit to the human resource department together with the PAT certificate when seeking employments.

Recently, Edward Co.,LTD joins PAT Alliance and sets their green channel preferential conditions to 80 points of PAT Advanced Level. That means you can enter the green channel if you get 80 points or above on PAT Advanced Level. Now Edward Co.,LTD gets the result of all examinees, please tell them whether the examinee can get the chance of entering green channel.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The only line contains four integers ScoreAScoreBScoreC, and ScoreD - the four problems' score of the examinee.(0 <= ScoreA <= 20, 0 <= ScoreBScoreC <= 25, 0 <= ScoreD <= 30)

Output

For each test case, if the examinee gets 80 points or above in total, output "Yes", else output "No".

Sample Input
4
0 0 5 30
20 25 20 0
20 25 20 15
20 25 25 30
Sample Output
No
No
Yes
Yes
 
 
 
 
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <queue>

using namespace std;
int t;
int a,b,c,d;
int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{
	while(t--)
	{
		scanf("%d%d%d%d",&a,&b,&c,&d);
          if(a+b+c+d>=80)
			  printf("Yes\n");
		  else	
			  printf("No\n");
	}
	}
	return 0;
}

 

转载于:https://www.cnblogs.com/dacc123/p/8228730.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值