poj 1978 Hanafuda Shuffle

Hanafuda Shuffle
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3395 Accepted: 1939

Description

There are a number of ways to shuffle a deck of cards. Hanafuda shuffling for Japanese card game 'Hanafuda' is one such example. The following is how to perform Hanafuda shuffling.

There is a deck of n cards. Starting from the p-th card from the top of the deck, c cards are pulled out and put on the top of the deck, as shown in Figure 1. This operation, called a cutting operation, is repeated.

Write a program that simulates Hanafuda shuffling and answers which card will be finally placed on the top of the deck.

Figure 1: Cutting operation

Input

The input consists of multiple data sets. Each data set starts with a line containing two positive integers n (1 <= n <= 50) and r (1 <= r <= 50); n and r are the number of cards in the deck and the number of cutting operations, respectively.

There are r more lines in the data set, each of which represents a cutting operation. These cutting operations are performed in the listed order. Each line contains two positive integers p and c (p + c <= n + 1). Starting from the p-th card from the top of the deck, c cards should be pulled out and put on the top.

The end of the input is indicated by a line which contains two zeros.

Each input line contains exactly two integers separated by a space character. There are no other characters in the line.

Output

For each data set in the input, your program should write the number of the top card after the shuffle. Assume that at the beginning the cards are numbered from 1 to n, from the bottom to the top. Each number should be written in a separate line without any superfluous characters such as leading or following spaces.

Sample Input

5 2
3 1
3 1
10 3
1 10
10 1
8 3
0 0

Sample Output

4
4
#include<iostream>
using namespace std;
int main()
{
int n,r;
int card[51];
int temp[51];
int p,c;
// freopen("E:\\c++\\oj\\t.txt","rt",stdin);
while(1)
{
cin>>n>>r;
if(n==0&&r==0)
break;
int t=n;
for(int i=1;i<=n;i++)
{
card[i]=t;
t--;
}

for(int j=0;j<r;j++)
{
cin>>p>>c;
for(int m=p,n=1;n<=c;m++,n++)
{
temp[m]=card[m];
}
int x=p+c-1;
for(int m=p-1;m>=1;m--)
{
card[x]=card[m];
x--;
}
for(int m=p,n=1;n<=c;m++,n++)
{
card[n]=temp[m];
}
}
cout<<card[1]<<endl;
}
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/21/2258179.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值