HDU 2955 Robberies(01背包的概率问题)

 

          Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4953    Accepted Submission(s): 1878


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

 

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
 

 

Sample Output
2
4
6
 

 

Source
 

 

Recommend
gaojie
 
 
 

一题很有启发性的DP规划,DP是一种思想,如果被固定的方法限定死了,就不算真正掌握DP。

这题一看题目,以为就是简单的背包,但不要理解错题意,总的概率不等于在各个银行不被抓概率的总和,在这里要做一个简单的转化,把每个银行的储钱量之和当成背包容量,然后概率当成价值来求。这里是被抓的概率,我们把它转化成不被抓的概率,然后这里的和就可以转化成乘积了,这样一来,我们就得到一个可以垒乘的状态转移方程(传统的背包上是垒加),我们求出抢j钱的最大不被抓概率,最后再枚举一下就行了。这就转化成了01背包问题。

状态转移方程:dp[j]=Max(dp[j],dp[j-Mj[i]]*(1-Pj[i]));

 

 

#include<iostream>
using namespace std;
double dp[10000];//dp[x]表示抢到x钱不被抓的概率
double Max(double x,double y)
{
    return x>y?x:y;
}
int main()
{
    int T,N,Mj[500];
    double P,Pj[500];
    int i,j,money,sum;
    cin>>T;
    while(T--)
    {
        money=0;
        sum=0;
        cin>>P>>N;
        for(i=0;i<N;i++)
        {
            cin>>Mj[i]>>Pj[i];
            money+=Mj[i];/*用可以抢到的总的银行储钱量当成背包的容量.
那么每个银行的储钱量就相当于每件物品所占的容量*/
} memset(dp,0,sizeof(dp)); dp[0]=1;//抢到0钱不被抓的概率为1 for(i=0;i<N;i++) { for(j=money;j>=Mj[i];j--) { dp[j]=Max(dp[j],dp[j-Mj[i]]*(1-Pj[i])); } } for(i=money;i>=0;i--) if(dp[i]>=1-P) { cout<<i<<endl; break; } } return 0; }


 

转载于:https://www.cnblogs.com/Su-Blog/archive/2012/08/18/2645642.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值