zcmu 1092

1092: 输出一个整数的各位数字

Description

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:
输入一个整数,从高位开始逐位输出它的各位数字。

Input

输入的整数可能大于1030

Output

见sample

Sample Input

3 123456 -600 8

Sample Output

1 2 3 4 5 6 6 0 0 8
 
思路:如果用数字来模拟除法,数字太大结果就不对。换一个思路,改用字符数组输入,如果遇到负号,从下标1开始打印,别的从下标0开始打印。
 
代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#include<time.h>
using namespace std;
#define FORA(i,x,y) for(int i = x; i < y; i++)
#define FORB(i,x,y) for(int i = x; i <= y; i++)
#define FORC(i,y,x) for(int i = y; i > x; i--)
#define maxn 100000
#define INF 1000000000
#define LL long long
const int mod = 1000000;
int a[maxn];
char b[maxn];
int main(){
    int t;
    scanf("%d",&t);
    getchar();
    while(t--){
        gets(b);
        if(b[0] == '-') {
            printf("%c",b[1]);
            FORA(i,2,strlen(b)){
                printf(" %c",b[i]);
            }
        }else {
            printf("%c",b[0]);
            FORA(i,1,strlen(b)) {
                printf(" %c",b[i]);
            }
        }
        printf("\n");
    }
    return 0;
}
 

转载于:https://www.cnblogs.com/banyouxia/p/9445717.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值