【TOJ 3812】Find the Lost Sock(异或)

描述

Alice bought a lot of pairs of socks yesterday. But when she went home, she found that she has lost one of them. Each sock has a name which contains exactly 7 charaters.

Alice wants to know which sock she has lost. Maybe you can help her.

输入

There are multiple cases. The first line containing an integer n (1 <= n <= 1000000) indicates that Alice bought n pairs of socks. For the following 2*n-1 lines, each line is a string with 7 charaters indicating the name of the socks that Alice took back.

输出

The name of the lost sock.

样例输入

2
aabcdef
bzyxwvu
bzyxwvu
4
aqwerty
eas fgh
aqwerty
easdfgh
easdfgh
aqwerty
aqwerty
2
0x0abcd
0ABCDEF
0x0abcd

样例输出

aabcdef
eas fgh
0ABCDEF

提示

Because of HUGE input, scanf is recommended.

#include<bits/stdc++.h>
using namespace std;
char a[8],x[8],ch;
int main()
{
    int i,j,n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        getchar();
        for(i=1;i<=2*n-1;i++)
        {
            for(j=0;j<7;j++)
            {
                ch=getchar();
                x[j]=ch;
                a[j]^=x[j];
            }
            getchar();
        }    
        a[7]='\0';
        printf("%s\n",a);
    }
    return 0;
}

转载于:https://www.cnblogs.com/kannyi/p/8996477.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值