HDU 4452 Running Rabbits

HDU 4452 Running Rabbits

题目链接http://acm.split.hdu.edu.cn/showproblem.php?pid=4452

Description

Rabbit Tom and rabbit Jerry are running in a field. The field is an N×N grid. Tom starts from the up-left cell and Jerry starts from the down-right cell. The coordinate of the up-left cell is (1,1) and the coordinate of the down-right cell is (N,N)。A 4×4 field and some coordinates of its cells are shown below:4452-1.jpg
The rabbits can run in four directions (north, south, west and east) and they run at certain speed measured by cells per hour. The rabbits can't get outside of the field. If a rabbit can't run ahead any more, it will turn around and keep running. For example, in a 5×5 grid, if a rabbit is heading west with a speed of 3 cells per hour, and it is in the (3, 2) cell now, then one hour later it will get to cell (3,3) and keep heading east. For example again, if a rabbit is in the (1,3) cell and it is heading north by speed 2,then a hour latter it will get to (3,3). The rabbits start running at 0 o'clock. If two rabbits meet in the same cell at k o'clock sharp( k can be any positive integer ), Tom will change his direction into Jerry's direction, and Jerry also will change his direction into Tom's original direction. This direction changing is before the judging of whether they should turn around.
The rabbits will turn left every certain hours. For example, if Tom turns left every 2 hours, then he will turn left at 2 o'clock , 4 o'clock, 6 o'clock..etc. But if a rabbit is just about to turn left when two rabbit meet, he will forget to turn this time. Given the initial speed and directions of the two rabbits, you should figure out where are they after some time.

Input

There are several test cases.
For each test case:
The first line is an integer N, meaning that the field is an N×N grid( 2≤N≤20).
The second line describes the situation of Tom. It is in format "c s t"。c is a letter indicating the initial running direction of Tom, and it can be 'W','E','N' or 'S' standing for west, east, north or south. s is Tom's speed( 1≤s<N). t means that Tom should turn left every t hours( 1≤ t ≤1000).
The third line is about Jerry and it's in the same format as the second line.
The last line is an integer K meaning that you should calculate the position of Tom and Jerry at K o'clock( 1 ≤ K ≤ 200).
The input ends with N = 0.

Output

For each test case, print Tom's position at K o'clock in a line, and then print Jerry's position in another line. The position is described by cell coordinate.

Sample Input

4
E 1 1
W 1 1
2
4
E 1 1
W 2 1
5
4
E 2 2
W 3 1
5
0

Sample Output

2 2
3 3
2 1
2 4
3 1
4 1

题意:

给你两个兔子,一个在(1,1)一个在(n,n)两个分别给一个初始方向和每秒速度和隔多少秒左转。如果撞到墙则反向运动。如果在某一秒两个兔子在同一个格子。那么交换运动方向。如果交换方向和左转冲突那么交换方向不左转。求第t秒的两个兔子坐标。

题解:

相机包模拟~

代码:

#include <bits/stdc++.h>
using namespace std;
int dx[]={-1,0,1, 0};
int dy[]={ 0,1,0,-1};
struct node{
    int x,y;
    int dir;;  
}A,B;

int getdir(char c)
{
    if (c == 'N')      return 0;
    else if (c == 'E') return 1;
    else if (c == 'S') return 2;
    else if (c == 'W') return 3;  
}
void getac(int n,node &A)
{
    while (true){
        if (A.x <= n && A.x >= 1)
            break;   
        if (A.x < 1){
            A.x = (2-A.x);
            A.dir = (A.dir+2)%4;
        }
        else if (A.x > n){
            A.x = n*2-A.x;
            A.dir = (A.dir+2)%4;
        }
    }
    while (true){
        if (A.y <= n && A.y >= 1)
            break;
        if (A.y < 1){
            A.y = (2-A.y);
            A.dir = (A.dir+2)%4;
        }
        else if (A.y > n){
            A.y = n*2-A.y;
            A.dir = (A.dir+2)%4;
        }
    }
}

int main()
{
    int n;
    char in1[5],in2[5];
    int v1,v2,t1,t2;
    while (scanf("%d",&n)&&(n!=0)){
        scanf("%s %d %d",in1,&v1,&t1);
        scanf("%s %d %d",in2,&v2,&t2);
        int t;
        A.dir = getdir(in1[0]);
        B.dir = getdir(in2[0]);
        A.x = A.y = 1;
        B.x = B.y = n;
        scanf("%d",&t);
        for (int i = 1;i <= t;i++){

            A.x += dx[A.dir]*v1;
            A.y += dy[A.dir]*v1;
            B.x += dx[B.dir]*v2;
            B.y += dy[B.dir]*v2;

            getac(n,A);
            getac(n,B);  

            if (A.x == B.x && A.y == B.y){
                swap(A.dir,B.dir);
                continue;
            }
            if (i%t1 == 0)
                A.dir = (A.dir-1+4)%4;   
            if (i%t2 == 0)
                B.dir = (B.dir-1+4)%4;
        }

        cout<<A.x<<" "<<A.y<<endl;
        cout<<B.x<<" "<<B.y<<endl;
    }
    return 0;    
}
posted @ 2016-08-20 13:01 Thecoollight 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/thecoollight/p/5790233.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值