SCU 4438 Censor(哈希+模拟栈)

 

Censor

frog is now a editor to censor so-called sensitive words (敏感词).

She has a long text \(p\). Her job is relatively simple -- just to find the first occurence of sensitive word \(w\) and remove it.

frog repeats over and over again. Help her do the tedious work.

Input

The input consists of multiple tests. For each test:

The first line contains \(1\) string \(w\). The second line contains \(1\) string \(p\).

(\(1 \leq \textrm{length of}\ w, p \leq 5 \cdot 10^6\)\(w, p\) consists of only lowercase letter)

Output

For each test, write \(1\) string which denotes the censored text.

Sample Input

    abc
    aaabcbc
    b
    bbb
    abc
    ab

Sample Output

    a
    
    ab

 

题目链接:SCU 4438

用哈希来做的话比KMP简单很多,每一次加入一个字符,看倒数Len个字符的哈希值是否和模式串相同,若相同则弹出Len个元素,否则再加入元素并更新哈希值

代码:

#include <stdio.h>
#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
typedef pair<int, int> pii;
typedef unsigned long long ULL;
const double PI = acos(-1.0);
const int N = 5e6 + 7;
const ULL seed = 1e9 + 7;
char w[N], p[N], ans[N];
int lw, lp;
ULL prefix[N] = {1ull}, st[N];

ULL gethash(char s[], int len)
{
    ULL hashval = 0ull;
    for (int i = 0; i < len; ++i)
        hashval = hashval * seed + s[i];
    return hashval;
}

int main(void)
{
    int i;
    for (i = 1; i < N; ++i)
        prefix[i] = prefix[i - 1] * seed;
    while (~scanf("%s%s", w, p))
    {
        lw = strlen(w);
        lp = strlen(p);
        ULL tar = gethash(w, lw);
        int top = 0;
        st[top] = 0;
        for (i = 0; i < lp; ++i)
        {
            ans[top++] = p[i];
            st[top] = st[top - 1] * seed + p[i];
            if (top >= lw && st[top] - st[top - lw]*prefix[lw] == tar)
                top -= lw;
        }
        ans[top] = '\0';
        printf("%s\n", ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/Blackops/p/6661562.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值