Codeforces Round #296 (Div. 2) C. Glass Carving(想法题)

传送门

Description

Leonid wants to become a glass carver (the person who creates beautiful artworks by cutting the glass). He already has a rectangular wmm  ×  h mm sheet of glass, a diamond glass cutter and lots of enthusiasm. What he lacks is understanding of what to carve and how.

In order not to waste time, he decided to practice the technique of carving. To do this, he makes vertical and horizontal cuts through the entire sheet. This process results in making smaller rectangular fragments of glass. Leonid does not move the newly made glass fragments. In particular, a cut divides each fragment of glass that it goes through into smaller fragments.

After each cut Leonid tries to determine what area the largest of the currently available glass fragments has. Since there appear more and more fragments, this question takes him more and more time and distracts him from the fascinating process.

Leonid offers to divide the labor — he will cut glass, and you will calculate the area of the maximum fragment after each cut. Do you agree?

Input

The first line contains three integers w, h, n (2 ≤ w, h ≤ 200 000, 1 ≤ n ≤ 200 000).

Next n lines contain the descriptions of the cuts. Each description has the form H y or V x. In the first case Leonid makes the horizontal cut at the distance y millimeters (1 ≤ y ≤ h - 1) from the lower edge of the original sheet of glass. In the second case Leonid makes a vertical cut at distance x (1 ≤ x ≤ w - 1) millimeters from the left edge of the original sheet of glass. It is guaranteed that Leonid won't make two identical cuts.

Output

After each cut print on a single line the area of the maximum available glass fragment in mm2.

Sample Input

4 3 4
H 2
V 2
V 3
V 1

7 6 5
H 4
V 3
V 5
H 2
V 1

Sample Output

8
4
4
2

28
16
12
6
4

Note

Picture for the first sample test:

Picture for the second sample test:

思路

题意:

给定一个矩形,每次切一刀,求出每次余下区域中最大的面积的值。

题解:

很容易知道,余下区域中面积最大的,即被分割后长度最长的乘以被分割后宽度最长的。构造一个元素集记录所切位置,然后求出每次切一刀后,减少的长度以及新增的长度。

 

#include<bits/stdc++.h>
using namespace std;
typedef __int64 LL;
const int maxn = 200005;
set<int>sw,sh;
set<int>::iterator font,rear;
int w[maxn],h[maxn];

void solve(set<int>&s,int *a,int p)
{
	s.insert(p);
	font = rear = s.find(p);
	font--;rear++;
	--a[*rear - * font];
	++a[p - *font];
	++a[*rear - p];
}

int main()
{
	//freopen("input.txt","r",stdin);
	//freopen("output.txt","w",stdout);
	int ww,hh,n,tmp;
	char hv[5];
	memset(w,0,sizeof(w));
	memset(h,0,sizeof(h));
	scanf("%d%d%d",&ww,&hh,&n);
	sw.insert(0),sh.insert(0);
	sw.insert(ww),sh.insert(hh);
	h[0] = h[hh] = 1;
	w[0] = w[ww] = 1;
	int maxw = ww,maxh = hh;
	while (n--)
	{
		scanf("%s %d",hv,&tmp);
		if (hv[0] == 'H')	solve(sh,h,tmp);
		else	solve(sw,w,tmp);
		while (!w[maxw])	maxw--;
		while (!h[maxh])	maxh--;
		printf("%I64d\n",LL(maxw)*LL(maxh));
	}
	return 0;
}

  

转载于:https://www.cnblogs.com/ZhaoxiCheung/p/6741443.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值