hdu 4357 String change(推理题,4级)

String change

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 802    Accepted Submission(s): 370


Problem Description
In this problem you will receive two strings S 1 and S 2 that contain only lowercase letters.
Each time you can swap any two characters of S 1. After swap,both of the two letters will increase their value by one. If the previous letter is 'z',it will become 'a' after being swapped.
That is to say ,"a" becomes "b","b" becomes "c"....."z" becomes "a" and so on.
You can do the change operation in S 1 as many times as you want.
Please tell us whether you can change S 1 to S 2 after some operations or not.
 

Input
There are several cases.The first line of the input is a single integer T (T <= 41) which is the number of test cases.Then comes the T test cases .

For each case,the first line is S 1,the second line is S 2.S 1 has the same length as S 2 and the length of the string is between 2 and 60.
 

Output
For each case,output "Case #X: " first, X is the case number starting from 1.If it is possible change S 1 to S 2 output "YES",otherwise output "NO".
 

Sample Input
 
  
3 ab ba bac ddb aaabb cbccd
 

Sample Output
 
  
Case #1: NO Case #2: YES Case #3: YES
Hint
For the first case,it's impossible to change "ab" to "ba" . For the second case,swap(S1[0],S1[2])->swap(S1[1],S1[2]),meanwhile:bac->dac->ddb. For the third case,swap(S1[0],S1[3])->swap(S1[1],S1[2])->swap(S1[2],S1[3])->swap(S1[3],S1[4]), meanwhile:aaabb->caabb->cbbbb->cbccb->cbccd.
 

Author
miketc@UESTC_Goldfinger
 

Source
 

Recommend
zhuyuanchen520

思路:推理后发现超过两张牌的情况,只要是奇偶一样都可以用变换。


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mm=99;
char s[mm],t[mm];
int cas;
int main()
{
  while(~scanf("%d",&cas))
  {
    for(int ca=1;ca<=cas;++ca)
    { scanf("%s%s",s,t);
      printf("Case #%d: ",ca);
      int len=strlen(s);
      bool a=0,b=0;
      bool flag=0;
      int k1,k2;
      if(len==2)
      { k1=(s[0]-t[0]+26)%26;
        k2=(s[1]-t[1]+26)%26;
        if(k1==k2&&k1%2==0)flag=1;
        k1=(s[0]-t[1]+26)%26;
        k2=(s[1]-t[0]+26)%26;
        if(k1==k2&&k1%2==1)flag=1;
        if(flag)printf("YES\n");
        else printf("NO\n");
      }
      else
      {
        for(int i=0;i<len;++i)
        {
          a^=s[i]&1;
          b^=t[i]&1;
        }
        if(a==b)printf("YES\n");
        else printf("NO\n");
      }
    }
  }
  return 0;
}


转载于:https://www.cnblogs.com/nealgavin/p/3205889.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值