Uva11732:"strcmp()" Anyone?

Problem

strcmp() is a library function in C/C++ which compares two strings. It takes two strings as input
parameter and decides which one is lexicographically larger or smaller: If the first string is greater then
it returns a positive value, if the second string is greater it returns a negative value and if two strings
are equal it returns a zero. The code that is used to compare two strings in C/C++ library is shown
below:

int strcmp(char *s,char *t)
{
    int i;
    for(i=0;s[i]==t[i];i++)
        if(s[i]=='\0') return 0;
    return s[i]-t[i];
}

Figure: The standard strcmp() code provided for this problem.
The number of comparisons required to compare two strings in strcmp() function is never returned
by the function. But for this problem you will have to do just that at a larger scale. strcmp() function
continues to compare characters in the same position of the two strings until two different characters
are found or both strings come to an end. Of course it assumes that last character of a string is a null
(‘\0’) character. For example the table below shows what happens when “than” and “that”; “therE”
and “the” are compared using strcmp() function. To understand how 7 comparisons are needed in
both cases please consult the code block given above.
1174888-20180102213733674-111434867.png

Input

The input file contains maximum 10 sets of inputs. The description of each set is given below:
Each set starts with an integer N (0 < N < 4001) which denotes the total number of strings. Each
of the next N lines contains one string. Strings contain only alphanumerals (‘0’...‘9’, ‘A’...‘Z’, ‘a’...‘z’)
have a maximum length of 1000, and a minimum length of 1.
Input is terminated by a line containing a single zero.

Output

For each set of input produce one line of output. This line contains the serial of output followed by
an integer T. This T denotes the total number of comparisons that are required in the strcmp()
function if all the strings are compared with one another exactly once. So for N strings the function
strcmp() will be called exactly N(N−1)/2 times. You have to calculate total number of comparisons
inside the strcmp() function in those N(N−1)/2 calls. You can assume that the value of T will fit safely
in a 64-bit signed integer. Please note that the most straightforward solution (Worst Case Complexity
O(N²*1000) will time out for this problem.

Sample Input

2
a
b
4
cat
hat
mat
sir
0

Sample Output

Case 1: 1
Case 2: 6


想法

这题一开始看还是挺简单的。
一眼看出用trie,到树的每一个分叉计算子树互相比较次数
但是细节好多啊!!!

要分3种情况:

1.两个单词完全相同

设单词长度为len
则比较次数为2×(len+1)

2.一个单词包含另一个单词

设短的单词长度为len
则比较次数为2×len+1

3.其他情况

设两个单词相同部分长度为len
则比较次数为len×2+1

trie每个节点要记下flag(有多少单词在当前点结束)与size(当前点及其子树中共多少单词)
每种情况在计算中都要判断


代码:
(注意:答案要转long long)

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

const int N = 4005;
typedef long long ll;

struct trie {
    trie *ch[65];
    int flag,size;
    void clear(){
        flag=size=0;
        for(int i=0;i<63;i++) ch[i]=NULL;     
    }
}pool[N*1005],*root;
int cnt;

int get(char s){
    if(s>='0' && s<='9') return s-'0';
    else if(s>='A' && s<='Z') return s-'A'+10;
    return s-'a'+36;    
}
void add(){
    char s[1005];
    scanf("%s",s);
    int len=strlen(s),id;
    trie *p=root;
    p->size++;
    for(int i=0;i<len;i++){
        id=get(s[i]); 
        if(!p->ch[id]){
            pool[++cnt].clear();
            p->ch[id]=&pool[cnt];
        }
        p=p->ch[id];
        p->size++;
    }
    p->flag++;
}
ll dfs(trie *p,int dep){
    int size=0;
    ll ret=0;
    size=p->size-p->flag;
    for(int i=0;i<63;i++)
        if(p->ch[i])
            ret+=((ll)size-p->ch[i]->size)*p->ch[i]->size*((ll)dep*2+1)+2*dfs(p->ch[i],dep+1);
    ret/=2;
    if(p->flag){
        ret+=(ll)p->flag*(p->flag-1)*(dep+1);
        ret+=(ll)p->flag*size*(dep*2+1);
    }
    return ret;
}

int n;

int main()
{
    int i,kase=0;
    root=&pool[++cnt];
    while(scanf("%d",&n) && n){
        cnt=1;
        pool[1].clear();
        for(i=0;i<n;i++) add();
        printf("Case %d: %lld\n",++kase,dfs(root,0));                    
    }

    return 0;    
}

转载于:https://www.cnblogs.com/lindalee/p/8179283.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
4S店客户管理小程序-毕业设计,基于微信小程序+SSM+MySql开发,源码+数据库+论文答辩+毕业论文+视频演示 社会的发展和科学技术的进步,互联网技术越来越受欢迎。手机也逐渐受到广大人民群众的喜爱,也逐渐进入了每个用户的使用。手机具有便利性,速度快,效率高,成本低等优点。 因此,构建符合自己要求的操作系统是非常有意义的。 本文从管理员、用户的功能要求出发,4S店客户管理系统中的功能模块主要是实现管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理,用户客户端:首页、车展、新闻头条、我的。门店客户端:首页、车展、新闻头条、我的经过认真细致的研究,精心准备和规划,最后测试成功,系统可以正常使用。分析功能调整与4S店客户管理系统实现的实际需求相结合,讨论了微信开发者技术与后台结合java语言和MySQL数据库开发4S店客户管理系统的使用。 关键字:4S店客户管理系统小程序 微信开发者 Java技术 MySQL数据库 软件的功能: 1、开发实现4S店客户管理系统的整个系统程序; 2、管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理等。 3、用户客户端:首页、车展、新闻头条、我的 4、门店客户端:首页、车展、新闻头条、我的等相应操作; 5、基础数据管理:实现系统基本信息的添加、修改及删除等操作,并且根据需求进行交流信息的查看及回复相应操作。
现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本微信小程序医院挂号预约系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此微信小程序医院挂号预约系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。微信小程序医院挂号预约系统有管理员,用户两个角色。管理员功能有个人中心,用户管理,医生信息管理,医院信息管理,科室信息管理,预约信息管理,预约取消管理,留言板,系统管理。微信小程序用户可以注册登录,查看医院信息,查看医生信息,查看公告资讯,在科室信息里面进行预约,也可以取消预约。微信小程序医院挂号预约系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值